summaryrefslogtreecommitdiff
path: root/mktrayicon/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-02-12 00:43:00 +0000
committerB Stack <bgstack15@gmail.com>2020-02-12 00:43:00 +0000
commit69001f6e35ac4d49d6ceab76344854fa77e808e2 (patch)
treeae20854b6feb039bcc7f92c145b7ff264f1d9130 /mktrayicon/debian/rules
parentMerge branch 'xdg-themes-stackrpms-bump' into 'master' (diff)
parentadd xdgmenumaker-user script and menu entry (diff)
downloadstackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.tar.gz
stackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.tar.bz2
stackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.zip
Merge branch 'updates' into 'master'
veracrypt, xdgmenumaker, ublock-origin, notepadpp, palemoon, xseticon dpkg Closes #16 See merge request bgstack15/stackrpms!122
Diffstat (limited to 'mktrayicon/debian/rules')
-rwxr-xr-xmktrayicon/debian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/mktrayicon/debian/rules b/mktrayicon/debian/rules
new file mode 100755
index 0000000..03d51b7
--- /dev/null
+++ b/mktrayicon/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export MD2MAN=go-md2man
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build
+ $$MD2MAN < README.md > debian/mktrayicon.1
+
+#override_dh_auto_install:
+# dh_auto_install -- prefix=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+
+override_dh_auto_clean:
+ dh_auto_clean || :
+ rm debian/mktrayicon.1 || :
bgstack15