summaryrefslogtreecommitdiff
path: root/makemkv-oss/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-03-02 13:43:17 -0500
committerB Stack <bgstack15@gmail.com>2019-03-02 13:43:17 -0500
commit780277c87cc3777621cfff519076c3a5eedd319c (patch)
treec451a808ea488af7f0cb680dbfbd93b9d3d59b42 /makemkv-oss/debian/rules
parentMerge branch 'irfanview-dpkg' into 'master' (diff)
downloadstackrpms-780277c87cc3777621cfff519076c3a5eedd319c.tar.gz
stackrpms-780277c87cc3777621cfff519076c3a5eedd319c.tar.bz2
stackrpms-780277c87cc3777621cfff519076c3a5eedd319c.zip
makemkv 1.14.2
Diffstat (limited to 'makemkv-oss/debian/rules')
-rwxr-xr-xmakemkv-oss/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/makemkv-oss/debian/rules b/makemkv-oss/debian/rules
new file mode 100755
index 0000000..4ebd7bb
--- /dev/null
+++ b/makemkv-oss/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ #https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887390 skip the --runstatedir=/run
+ ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=\${prefix}/lib/x86_64-linux-gnu --libexecdir=\${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking
+
+override_dh_auto_clean:
+ dh_auto_clean
+ /bin/rm -f config.log config.status Makefile libffabi/src/ffabicfg.h libtool
bgstack15