summaryrefslogtreecommitdiff
path: root/makemkv-bin/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-03-13 15:48:40 +0000
committerB Stack <bgstack15@gmail.com>2019-03-13 15:48:40 +0000
commit3d84691ab40d7e2fe5ddf86b8fe95cf3be93dd50 (patch)
tree031b667d1809460f216089e819c58e47d9a519d1 /makemkv-bin/debian/rules
parentMerge branch 'freefilesync-bump' into 'master' (diff)
parentadd more lines to conf example (diff)
downloadstackrpms-3d84691ab40d7e2fe5ddf86b8fe95cf3be93dd50.tar.gz
stackrpms-3d84691ab40d7e2fe5ddf86b8fe95cf3be93dd50.tar.bz2
stackrpms-3d84691ab40d7e2fe5ddf86b8fe95cf3be93dd50.zip
Merge branch 'makemkv-dpkg' into 'master'
Makemkv dpkg See merge request bgstack15/stackrpms!47
Diffstat (limited to 'makemkv-bin/debian/rules')
-rwxr-xr-xmakemkv-bin/debian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/makemkv-bin/debian/rules b/makemkv-bin/debian/rules
new file mode 100755
index 0000000..c68e196
--- /dev/null
+++ b/makemkv-bin/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+#override_dh_auto_install:
+# dh_auto_install -- prefix=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+
+override_dh_auto_build:
+ mkdir -p tmp
+ echo accepted > tmp/eula_accepted
+ dh_auto_build
+
+override_dh_auto_clean:
+ rm -f tmp/eula_accepted
+ rmdir tmp || :
+ dh_auto_clean
bgstack15