summaryrefslogtreecommitdiff
path: root/librewolf/debian/dh
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2022-01-05 16:21:31 -0500
committerB. Stack <bgstack15@gmail.com>2022-01-05 16:21:31 -0500
commit826a2e7f8c7786acb3b5d2217f19814f314289ab (patch)
tree9c1b67262b407684d8874fc9f525042c90d88207 /librewolf/debian/dh
parentcheck gcc ver instead of fedora ver (diff)
downloadstackrpms-826a2e7f8c7786acb3b5d2217f19814f314289ab.tar.gz
stackrpms-826a2e7f8c7786acb3b5d2217f19814f314289ab.tar.bz2
stackrpms-826a2e7f8c7786acb3b5d2217f19814f314289ab.zip
add initial lw d/ contents
Diffstat (limited to 'librewolf/debian/dh')
-rwxr-xr-xlibrewolf/debian/dh25
1 files changed, 25 insertions, 0 deletions
diff --git a/librewolf/debian/dh b/librewolf/debian/dh
new file mode 100755
index 0000000..5b43536
--- /dev/null
+++ b/librewolf/debian/dh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Wrapper around dh to enable parallelism in debian/rules if not already
+# enabled.
+
+case "$MAKEFLAGS" in
+*-j*)
+ # Already enabled, do nothing.
+ ;;
+*)
+ parallel=
+ for opt in "$DEB_BUILD_OPTIONS"; do
+ case "$opt" in
+ parallel=*)
+ parallel=${opt#parallel=}
+ ;;
+ esac
+ done
+ if [ -n "$parallel" ]; then
+ export MAKEFLAGS="-j$parallel${MAKEFLAGS:+ $MAKEFLAGS}"
+ fi
+ ;;
+esac
+
+exec dh "$@"
bgstack15