summaryrefslogtreecommitdiff
path: root/freefilesync/freefilesync.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-06-15 10:03:09 -0400
committerB Stack <bgstack15@gmail.com>2019-06-15 10:03:09 -0400
commite5432efea618b884e41f766813655db52c086522 (patch)
tree3964f2a2ff7bcefbfc1adee93256eafea4a9ae7e /freefilesync/freefilesync.spec
parentMerge branch 'scite-bump' into 'master' (diff)
downloadstackrpms-e5432efea618b884e41f766813655db52c086522.tar.gz
stackrpms-e5432efea618b884e41f766813655db52c086522.tar.bz2
stackrpms-e5432efea618b884e41f766813655db52c086522.zip
freefilesync 10.13 rpm rc1
Fixes #8 .desktop file is missing mimetypes: Added the hooks for dealing with mimetypes, and the icons, and the desktop file mimetype info
Diffstat (limited to 'freefilesync/freefilesync.spec')
-rw-r--r--freefilesync/freefilesync.spec41
1 files changed, 24 insertions, 17 deletions
diff --git a/freefilesync/freefilesync.spec b/freefilesync/freefilesync.spec
index fb7c4a3..0b3c344 100644
--- a/freefilesync/freefilesync.spec
+++ b/freefilesync/freefilesync.spec
@@ -14,7 +14,7 @@
%define min_openssl >= 1.1.0h
%endif
Name: freefilesync
-Version: 10.12
+Version: 10.13
Release: 1%{?dist}
Summary: A file synchronization utility
@@ -100,12 +100,12 @@ find . ! -type d \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) \
%build
%if !%{dummy_package}
%if "%{?scl_env}" != ""
- scl enable %{scl_env} /bin/bash << EOF
+ scl enable %{scl_env} /bin/bash << 'EOFSCL'
%endif
%make_build -C %{pkgname}/Source
%make_build -C %{pkgname}/Source/%{prog2name}
%if "%{?scl_env}" != ""
-EOF
+EOFSCL
%endif
%endif
@@ -117,7 +117,7 @@ EOF
pushd %{pkgname}/Build
install -d %{buildroot}%{_bindir} %{buildroot}%{_datadir}/%{name}
install -Dm 0755 -t %{buildroot}%{_bindir} Bin/%{pkgname} Bin/%{prog2name}
-cp -pr Languages Misc %{buildroot}%{_datadir}/%{name}
+cd Resources ; cp -pr * %{buildroot}%{_datadir}/%{name}
popd
%endif
@@ -140,16 +140,20 @@ install -d %{buildroot}%{_datadir}/mime/packages
install -Dm 0644 -t %{buildroot}%{_datadir}/mime/packages %{SOURCE3}
# icons
-unzip %{pkgname}/Build/Misc/Icons.zip file_batch.png
+unzip %{pkgname}/Build/Resources/Icons.zip file_batch.png file_sync.png
+ff=" -filter Lanczos"
for res in 16 22 24 32 48 64 96 128 256 ;do
- dir=%{buildroot}%{_datadir}/icons/hicolor/${res}x${res}/apps
- mkdir -p ${dir} ${dir}/../mimetypes
- for icon in %{pkgname} %{prog2name} ;do
- convert %{pkgname}/Build/Misc/${icon}.png -filter Lanczos -resize ${res}x${res} \
- ${dir}/${icon}.png
- done
- convert file_batch.png -filter Lanczos -resize ${res}x${res} ${dir}/../mimetypes/application-x-freefilesync-batch.png
+ dir=%{buildroot}%{_datadir}/icons/hicolor/${res}x${res}
+ rr=" -resize ${res}x${res}"
+ mkdir -p ${dir}/apps ${dir}/mimetypes
+ # apps
+ convert %{pkgname}/Build/Resources/%{pkgname}.png ${ff} ${rr} ${dir}/apps/%{pkgname}.png
+ convert %{pkgname}/Build/Resources/%{prog2name}.png ${ff} ${rr} ${dir}/apps/%{prog2name}.png
+ # mimetypes
+ convert file_batch.png ${ff} ${rr} ${dir}/mimetypes/application-x-freefilesync-batch.png
+ convert file_sync.png ${ff} ${rr} ${dir}/mimetypes/application-x-freefilesync-ffs.png
+ convert %{pkgname}/Build/Resources/%{prog2name}.png ${ff} ${rr} ${dir}/mimetypes/application-x-freefilesync-real.png
done
%clean
@@ -157,7 +161,6 @@ done
%post
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
-update-desktop-database &> /dev/null || :
%preun
# is it a final removal?
@@ -166,16 +169,15 @@ update-desktop-database &> /dev/null || :
#fi
%postun
-update-desktop-database &> /dev/null || :
if test "$1" = "0" ;
then
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
- gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi
%posttrans
-gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
-update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 || :
+update-desktop-database 1>/dev/null 2>&1 & :
+gtk-update-icon-cache %{_datadir}/icons/hicolor 1>/dev/null 2>&1 & :
+update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 & :
%files
%license %attr(444, -, -) License.txt
@@ -189,6 +191,11 @@ update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 || :
%ghost %config %attr(666, -, -) %{_datadir}/%{name}/GlobalSettings.xml
%changelog
+* Sat Jun 15 2019 B Stack <bgstack15@gmail.com> - 10.13-1
+- version bump
+- improve mimetype icon deployment
+
+- add mimetypes, to match dpkg
* Sun May 12 2019 B Stack <bgstack15@gmail.com> - 10.12-1
- version bump
- improve icons used from upstream, to match dpkg
bgstack15