summaryrefslogtreecommitdiff
path: root/freefilesync/freefilesync.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-02-14 18:20:14 +0000
committerB Stack <bgstack15@gmail.com>2019-02-14 18:20:14 +0000
commit899f8baa296bb3ebcb2a79d52113c1ddd643a08a (patch)
tree324a06c40b35c1ee785077e0a3c67b31d3a75e9e /freefilesync/freefilesync.spec
parentpm-ublock dpkg for devuan (diff)
parentFreeFileSync 10.9 rpm and dpkg (diff)
downloadstackrpms-899f8baa296bb3ebcb2a79d52113c1ddd643a08a.tar.gz
stackrpms-899f8baa296bb3ebcb2a79d52113c1ddd643a08a.tar.bz2
stackrpms-899f8baa296bb3ebcb2a79d52113c1ddd643a08a.zip
FreeFileSync 10.9 rpm and dpkg
Application changes * Added FTP, SFTP, Google Drive support for Linux * FreeFileSync Donation Edition available for Linux * Compress file stream during Google Drive upload * Navigate beyond access-denied parents in SFTP folder picker * Fixed unexpected stream size error during FTP upload * Support native recursive deletion for Google Drive * Support native recursive deletion for MTP * Deterministically save Google Drive state during exit * Work around missing TMPDIR variable (Linux) * Support SFTP servers returning large package sizes during folder reading * Start with home path when using SFTP folder picker * Aggregate device authentication prompts during comparison * Clean up temp file after unexpected stream size error * Work around FTP servers not supporting HELP command * Support parsing path by volume name when volume is missing * Parse and streamline Google Drive error messages * Load next item after deleting from config history * Avoid redundant Google Drive syncs after file/folder creation * Avoid duplicate MTP item creation by multiple threads Package changes * Upstream removed Makefile install target, so each package implements basically identical, local install targets * Added patches for older versions of dependencies which do not alter basic usage of the application See merge request bgstack15/stackrpms!37
Diffstat (limited to 'freefilesync/freefilesync.spec')
-rw-r--r--freefilesync/freefilesync.spec40
1 files changed, 30 insertions, 10 deletions
diff --git a/freefilesync/freefilesync.spec b/freefilesync/freefilesync.spec
index 3ae7f2d..591adbf 100644
--- a/freefilesync/freefilesync.spec
+++ b/freefilesync/freefilesync.spec
@@ -2,7 +2,7 @@
%global prog2name RealTimeSync
%global dummy_package 0
Name: freefilesync
-Version: 10.8
+Version: 10.9
Release: 1%{?dist}
Summary: A file synchronization utility
@@ -10,7 +10,7 @@ Group: Applications/File
License: GPLv3
URL: http://www.freefilesync.org/
# upstream does not provide easy automatic downloads of the source, so use the mirror
-#Source0: http://www.freefilesync.org/download/%{pkgname}_%{version}_Source.zip
+#Source0: http://www.freefilesync.org/download/%%{pkgname}_%%{version}_Source.zip
Source0: https://gitlab.com/opensource-tracking/%{pkgname}/-/archive/%{version}/%{pkgname}-%{version}.tar.gz
Source1: %{pkgname}.desktop
Source2: %{prog2name}.desktop
@@ -18,14 +18,20 @@ Patch0: ffs_makefile.patch
Patch1: ffs_no_check_updates.patch
Patch2: ffs_no_wx311.patch
Patch3: ffs_fedora.patch
+Patch4: ffs_allow_parallel_ops.patch
+Patch5: ffs_old_libcurl.patch
+Patch6: ffs_sftp.patch
Packager: B Stack <bgstack15@gmail.com>
-BuildRequires: boost-devel
# WARNING: the build will FAIL if you have wxGTK3-devel installed. Only wxGTK2-devel should be on the build system.
+BuildRequires: boost-devel
BuildRequires: compat-wxGTK3-gtk2-devel
-BuildRequires: gcc-c++
BuildRequires: desktop-file-utils
+BuildRequires: gcc-c++
BuildRequires: ImageMagick
+BuildRequires: libcurl-devel
+BuildRequires: libssh2-devel
+BuildRequires: openssl-devel
BuildRequires: pkgconfig(gtk+-2.0)
BuildRequires: pkgconfig(libselinux)
BuildRequires: pkgconfig(zlib)
@@ -48,6 +54,9 @@ find . ! -type d \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) \
%patch1 -p1
%patch2 -p1
%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
# custom build parameters for packaging application in rpm
%{__sed} \
@@ -63,12 +72,19 @@ find . ! -type d \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) \
%install
%if !%{dummy_package}
-%make_install -C %{pkgname}/Source
-%make_install -C %{pkgname}/Source/%{prog2name}
+# removed by upstream!
+#%%make_install -C %%{pkgname}/Source
+#%%make_install -C %%{pkgname}/Source/%%{prog2name}
+pushd %{pkgname}/Build
+install -d %{buildroot}%{_bindir} %{buildroot}%{_datadir}/%{name}
+install -Dm 0755 -t %{buildroot}%{_bindir} Bin/%{pkgname} Bin/%{prog2name}
+cp -pr Languages %{buildroot}%{_datadir}/%{name}
+install -Dm 0644 ding.wav gong.wav harp.wav Resources.zip styles.gtk_rc %{buildroot}%{_datadir}/%{name}
+popd
%endif
# make extra sure the files are not marked with executable
-find %{buildroot}%{_datadir}/%{pkgname} -type f -exec chmod -x '{}' \; || :
+find %{buildroot}%{_datadir}/%{name} -type f -exec chmod -x '{}' \; || :
# desktop files
mkdir -p %{buildroot}%{_datadir}/applications
@@ -127,11 +143,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_bindir}/%{prog2name}
%{_datadir}/applications/*.desktop
%{_datadir}/icons/hicolor/*x*/apps/*.png
-%{_datadir}/%{pkgname}
-%{_defaultdocdir}/%{pkgname}
-%ghost %config %attr(666, -, -) %{_datadir}/%{pkgname}/GlobalSettings.xml
+%{_datadir}/%{name}
+%ghost %config %attr(666, -, -) %{_datadir}/%{name}/GlobalSettings.xml
%changelog
+* Tue Feb 12 2019 B Stack <bgstack15@gmail.com> - 10.9-1
+- version bump
+- add manual install that is now absent from upstream
+- move datadir to lowercase name instead of camelcase
+
* Thu Jan 17 2019 B Stack <bgstack15@gmail.com> - 10.8-1
- version bump
bgstack15