summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-06-20 15:26:01 -0400
committerB Stack <bgstack15@gmail.com>2020-06-20 15:26:01 -0400
commitbe9c55eea9da9849722d90764ab9ef949ad14f8d (patch)
tree9d20ee1b2ea0869b1d009a3662b700d0f2093b0d /freefilesync/debian
parentMerge branch 'notepadpp-bump' into 'master' (diff)
downloadstackrpms-be9c55eea9da9849722d90764ab9ef949ad14f8d.tar.gz
stackrpms-be9c55eea9da9849722d90764ab9ef949ad14f8d.tar.bz2
stackrpms-be9c55eea9da9849722d90764ab9ef949ad14f8d.zip
freefilesync 10.25 dpkg rc1
now using g++-10 specifically
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/README.Debian4
-rw-r--r--freefilesync/debian/changelog6
-rw-r--r--freefilesync/debian/control9
-rw-r--r--freefilesync/debian/freefilesync+devuan.dsc2
-rw-r--r--freefilesync/debian/patches/ffs_gcc.patch46
-rw-r--r--freefilesync/debian/patches/ffs_no_wx311.patch18
-rw-r--r--freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch181
-rw-r--r--freefilesync/debian/patches/series1
8 files changed, 77 insertions, 190 deletions
diff --git a/freefilesync/debian/README.Debian b/freefilesync/debian/README.Debian
index 588db96..a5a1f01 100644
--- a/freefilesync/debian/README.Debian
+++ b/freefilesync/debian/README.Debian
@@ -1,3 +1,7 @@
+freefilesync (10.25-1+devuan)
+
+Now requires g++-10. Previously, the maintainer was reverting the logic only available to gcc-10, but this is becoming unmaintainable.
+
freefilesync (10.21-2+devuan)
* gtk2 build for albion
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index 0b9f910..d9eec71 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,9 @@
+freefilesync (10.25-1+devuan) obs; urgency=medium
+
+ * gtk3 build (unstable)
+
+ -- Ben Stack <bgstack15@gmail.com> Fri, 19 Jun 2020 16:21:17 -0400
+
freefilesync (10.24-2+devuan) albion; urgency=medium
* gtk2 build (stable)
diff --git a/freefilesync/debian/control b/freefilesync/debian/control
index 00da1a0..dfef1e5 100644
--- a/freefilesync/debian/control
+++ b/freefilesync/debian/control
@@ -4,6 +4,7 @@ Priority: optional
Maintainer: B Stack <bgstack15@gmail.com>
Build-Depends: debhelper (>=12~),
imagemagick,
+ g++-10,
libcurl4-openssl-dev (>=7.68.0),
libssh2-1-dev,
libssl-dev,
@@ -11,13 +12,13 @@ Build-Depends: debhelper (>=12~),
unzip,
# gtk2 version, now possible only with local devuan-archive, and these must be removed for gtk3 build
# install with sudo apt-get install libwxbase3.0-0v5=3.0.4+dfsg-14 libwxbase3.0-dev=3.0.4+dfsg-14 libwxgtk3.0-0v5=3.0.4+dfsg-14 libwxgtk3.0-dev=3.0.4+dfsg-14 wx3.0-headers=3.0.4+dfsg-14 libgtk2.0-dev
- libgtk2.0-dev,
- libwxgtk3.0-dev (=3.0.4+dfsg-14),
+# libgtk2.0-dev,
+# libwxgtk3.0-dev (=3.0.4+dfsg-14),
# gtk3 version, and these must be removed for gtk2 build
# install with sudo apt-get install libwxbase3.0-dev=3.0.4+dfsg-15 libwxbase3.0-0v5=3.0.4+dfsg-15 wx3.0-headers=3.0.4+dfsg-15 libgtk-3-dev libwxgtk3.0-gtk3-dev
# which will remove libwxbase3.0-dev=3.0.4+dfsg-14
-# libgtk-3-dev,
-# libwxgtk3.0-gtk3-dev,
+ libgtk-3-dev,
+ libwxgtk3.0-gtk3-dev,
Standards-Version: 4.1.4
Homepage: https://freefilesync.org/
diff --git a/freefilesync/debian/freefilesync+devuan.dsc b/freefilesync/debian/freefilesync+devuan.dsc
index eb4e5b1..1c2f3f8 100644
--- a/freefilesync/debian/freefilesync+devuan.dsc
+++ b/freefilesync/debian/freefilesync+devuan.dsc
@@ -2,7 +2,7 @@ Format: 3.0 (quilt)
Source: freefilesync
Binary: freefilesync
Architecture: any
-Version: 10.24-1+devuan
+Version: 10.25-1+devuan
Maintainer: B Stack <bgstack15@gmail.com>
Homepage: https://freefilesync.org/
Standards-Version: 4.1.4
diff --git a/freefilesync/debian/patches/ffs_gcc.patch b/freefilesync/debian/patches/ffs_gcc.patch
new file mode 100644
index 0000000..ed007b5
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_gcc.patch
@@ -0,0 +1,46 @@
+diff -Naur 10.25-1/FreeFileSync/Source/Makefile 10.25-2/FreeFileSync/Source/Makefile
+--- 10.25-1/FreeFileSync/Source/Makefile 2020-06-20 13:36:08.495867672 -0400
++++ 10.25-2/FreeFileSync/Source/Makefile 2020-06-20 13:31:36.180419862 -0400
+@@ -1,4 +1,5 @@
+ exeName = FreeFileSync
++CXX=g++-10
+
+ cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+@@ -114,11 +115,11 @@
+
+ ../Build/Bin/$(exeName): $(objFiles)
+ mkdir -p $(dir $@)
+- g++ -o $@ $^ $(linkFlags)
++ $(CXX) -o $@ $^ $(linkFlags)
+
+ $(tmpPath)/ffs/src/%.o : %
+ mkdir -p $(dir $@)
+- g++ $(cxxFlags) -c $< -o $@
++ $(CXX) $(cxxFlags) -c $< -o $@
+
+ clean:
+ rm -rf $(tmpPath)
+diff -Naur 10.25-1/FreeFileSync/Source/RealTimeSync/Makefile 10.25-2/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.25-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-06-20 13:36:08.499867723 -0400
++++ 10.25-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-06-20 13:31:48.844580205 -0400
+@@ -1,4 +1,5 @@
+ exeName = RealTimeSync
++CXX=g++-10
+
+ cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+@@ -52,11 +53,11 @@
+
+ ../../Build/Bin/$(exeName): $(objFiles)
+ mkdir -p $(dir $@)
+- g++ -o $@ $^ $(linkFlags)
++ $(CXX) -o $@ $^ $(linkFlags)
+
+ $(tmpPath)/ffs/src/rts/%.o : %
+ mkdir -p $(dir $@)
+- g++ $(cxxFlags) -c $< -o $@
++ $(CXX) $(cxxFlags) -c $< -o $@
+
+ clean:
+ rm -rf $(tmpPath)
diff --git a/freefilesync/debian/patches/ffs_no_wx311.patch b/freefilesync/debian/patches/ffs_no_wx311.patch
index 932800d..926f7b8 100644
--- a/freefilesync/debian/patches/ffs_no_wx311.patch
+++ b/freefilesync/debian/patches/ffs_no_wx311.patch
@@ -1,8 +1,18 @@
2019-08-15 just compile.
-diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.24-1/FreeFileSync/Source/ui/small_dlgs.cpp
---- 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 07:56:06.714625467 -0500
-+++ 10.19-1/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 08:41:43.498308243 -0500
-@@ -1594,7 +1594,7 @@
+diff -Naur 10.25-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.25-1/FreeFileSync/Source/ui/small_dlgs.cpp
+--- 10.25-0/FreeFileSync/Source/ui/small_dlgs.cpp 2020-06-19 16:17:15.000000000 -0400
++++ 10.25-1/FreeFileSync/Source/ui/small_dlgs.cpp 2020-06-20 14:23:47.488836409 -0400
+@@ -293,7 +293,8 @@
+ {
+ showNotificationDialog(this, DialogInfoType::error, PopupDialogCfg().setDetailInstructions(e.toString()));
+ }
+- m_listBoxGdriveUsers->Append(gdriveAccounts);
++ for (const wxString& item : gdriveAccounts) // reverted to pre-wx 3.1.1 logic
++ m_listBoxGdriveUsers->Append(item);
+
+ //set default values for Google Drive: use first item of m_listBoxGdriveUsers
+ if (!gdriveAccounts.empty() && !acceptsItemPathPhraseGdrive(folderPathPhrase))
+@@ -1663,7 +1664,7 @@
//setMainInstructionFont(*m_staticTextMain);
m_bitmapActivation->SetBitmap(getResourceImage("internet"));
diff --git a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
index 0da4e06..8ca60c2 100644
--- a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
+++ b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
@@ -1,184 +1,3 @@
-Author: Ben Stack <bgstack15@gmail.com>
-Date: 2020-05-17 14:11 -0400
-Message: Use the following command to get this old contents. Zenju must be using some newer definition of -std=c++2a than what Devuan Ceres provides as of 2020-05-17, and probably wxwidgets. This is the 10.23 code for these files.
-
- git checkout b4ecf755 zen/legacy_compiler.h zen/string_base.h wx+/choice_enum.h
-
-Unfortunately with the removal of the wxWidgets-gtk2 code from Debian, we are stuck using all available at approximately November 1, 2019 snapshot of Debian: https://snapshot.debian.org/archive/debian/20191101T211023Z/pool/main/w/wxwidgets3.0/
-libwxbase3.0-0v5_3.0.4+dfsg-14_amd64.deb
-libwxbase3.0-0v5_3.0.4+dfsg-14_i386.deb
-libwxbase3.0-dev_3.0.4+dfsg-14_amd64.deb
-libwxbase3.0-dev_3.0.4+dfsg-14_i386.deb
-libwxgtk3.0-0v5_3.0.4+dfsg-14_amd64.deb
-libwxgtk3.0-0v5_3.0.4+dfsg-14_i386.deb
-libwxgtk3.0-dev_3.0.4+dfsg-14_amd64.deb
-libwxgtk3.0-dev_3.0.4+dfsg-14_i386.deb
-wx3.0-headers_3.0.4+dfsg-14_all.deb
-wx-common_3.0.4+dfsg-14_amd64.deb
-wx-common_3.0.4+dfsg-14_i386.deb
-diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/zen/legacy_compiler.h 10.24-1/zen/legacy_compiler.h
---- 10.24-0/zen/legacy_compiler.h 2020-05-17 13:44:27.542140458 -0400
-+++ 10.24-1/zen/legacy_compiler.h 2020-05-17 14:07:49.115166339 -0400
-@@ -7,9 +7,6 @@
- #ifndef LEGACY_COMPILER_H_839567308565656789
- #define LEGACY_COMPILER_H_839567308565656789
-
-- #include <numbers> //C++20
--
-- #include <span> //requires C++20
-
-
-
-@@ -21,8 +18,53 @@
-
- //---------------------------------------------------------------------------------
-
-+#if __cpp_lib_span
-+ #error get rid of workaround:
-+#endif
-+
-+template <class T>
-+class span
-+{
-+public:
-+ template <class Iterator>
-+ span(Iterator first, Iterator last) : size_(last - first), data_(first != last ? &*first : nullptr) {}
-+
-+ template <class Container>
-+ span(Container& cont) : span(cont.begin(), cont.end()) {}
-+
-+ using iterator = T*;
-+ using const_iterator = const T*;
-+
-+ iterator begin() { return data_; }
-+ iterator end () { return data_ + size_; }
-+
-+ const_iterator begin() const { return data_; }
-+ const_iterator end () const { return data_ + size_; }
-
-+ const_iterator cbegin() const { return begin(); }
-+ const_iterator cend () const { return end (); }
-
-+ T* data() const { return data_; }
-+ size_t size() const { return size_; }
-+ bool empty() const { return size_ == 0; }
-+
-+private:
-+ const size_t size_;
-+ T* const data_;
-+};
-+
-+
-+#if __cpp_lib_math_constants
-+ #error get rid of workaround:
-+#endif
-+
-+namespace numbers
-+{
-+const double pi = 3.14159265358979323846;
-+const double e = 2.71828182845904523536;
-+const double sqrt2 = 1.41421356237309504880;
-+const double ln2 = 0.693147180559945309417;
-+}
- }
-
-
-diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/zen/string_base.h 10.24-1/zen/string_base.h
---- 10.24-0/zen/string_base.h 2020-05-17 13:44:27.554140569 -0400
-+++ 10.24-1/zen/string_base.h 2020-05-17 14:09:44.164244361 -0400
-@@ -12,7 +12,9 @@
- #include <cstdint>
- #include <atomic>
- #include "string_tools.h"
-+#if __cpp_impl_three_way_comparison && __cpp_lib_three_way_comparison
- #include <compare>
-+#endif
-
-
- //Zbase - a policy based string class optimizing performance and flexibility
-@@ -293,15 +295,29 @@
- };
-
-
-+#if __cpp_impl_three_way_comparison && __cpp_lib_three_way_comparison
-+ #error implement!
-+#endif
-+
-
- template <class Char, template <class> class SP> bool operator==(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs);
- template <class Char, template <class> class SP> bool operator==(const Zbase<Char, SP>& lhs, const Char* rhs);
- template <class Char, template <class> class SP> inline bool operator==(const Char* lhs, const Zbase<Char, SP>& rhs) { return operator==(rhs, lhs); }
-
-+#if __cpp_impl_three_way_comparison && __cpp_lib_three_way_comparison
- template <class Char, template <class> class SP> std::strong_ordering operator<=>(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs);
- template <class Char, template <class> class SP> std::strong_ordering operator<=>(const Zbase<Char, SP>& lhs, const Char* rhs);
- template <class Char, template <class> class SP> std::strong_ordering operator<=>(const Char* lhs, const Zbase<Char, SP>& rhs);
-
-+#else
-+template <class Char, template <class> class SP> inline bool operator!=(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs) { return !operator==(lhs, rhs); }
-+template <class Char, template <class> class SP> inline bool operator!=(const Zbase<Char, SP>& lhs, const Char* rhs) { return !operator==(lhs, rhs); }
-+template <class Char, template <class> class SP> inline bool operator!=(const Char* lhs, const Zbase<Char, SP>& rhs) { return !operator==(lhs, rhs); }
-+
-+template <class Char, template <class> class SP> bool operator<(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs);
-+template <class Char, template <class> class SP> bool operator<(const Zbase<Char, SP>& lhs, const Char* rhs);
-+template <class Char, template <class> class SP> bool operator<(const Char* lhs, const Zbase<Char, SP>& rhs);
-+#endif
-
- template <class Char, template <class> class SP> inline Zbase<Char, SP> operator+(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs) { return Zbase<Char, SP>(lhs) += rhs; }
- template <class Char, template <class> class SP> inline Zbase<Char, SP> operator+(const Zbase<Char, SP>& lhs, const Char* rhs) { return Zbase<Char, SP>(lhs) += rhs; }
-@@ -482,11 +498,12 @@
- }
-
-
-+#if __cpp_impl_three_way_comparison && __cpp_lib_three_way_comparison
- template <class Char, template <class> class SP> inline
- std::strong_ordering operator<=>(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs)
- {
-- return std::lexicographical_compare_three_way(lhs.begin(), lhs.end(), //respect embedded 0
-- rhs.begin(), rhs.end()); //
-+ return std::lexicographical_compare_three_way(lhs.begin(), lhs.end(), //respect embedded 0
-+ rhs.begin(), rhs.end());
- }
-
-
-@@ -501,11 +518,35 @@
- template <class Char, template <class> class SP> inline
- std::strong_ordering operator<=>(const Char* lhs, const Zbase<Char, SP>& rhs)
- {
-- return std::lexicographical_compare_three_way(lhs, lhs + strLength(lhs),
-- rhs.begin(), rhs.end()); //respect embedded 0
-+ return std::lexicographical_compare_three_way(lhs, lhs + strLength(lhs), //respect embedded 0
-+ rhs.begin(), rhs.end());
-+}
-+
-+#else
-+template <class Char, template <class> class SP> inline
-+bool operator<(const Zbase<Char, SP>& lhs, const Zbase<Char, SP>& rhs)
-+{
-+ return std::lexicographical_compare(lhs.begin(), lhs.end(), //respect embedded 0
-+ rhs.begin(), rhs.end());
- }
-
-
-+template <class Char, template <class> class SP> inline
-+bool operator<(const Zbase<Char, SP>& lhs, const Char* rhs)
-+{
-+ return std::lexicographical_compare(lhs.begin(), lhs.end(), //respect embedded 0
-+ rhs, rhs + strLength(rhs));
-+}
-+
-+
-+template <class Char, template <class> class SP> inline
-+bool operator<(const Char* lhs, const Zbase<Char, SP>& rhs)
-+{
-+ return std::lexicographical_compare(lhs, lhs + strLength(lhs), //respect embedded 0
-+ rhs.begin(), rhs.end());
-+}
-+#endif
-+
-
- template <class Char, template <class> class SP> inline
- size_t Zbase<Char, SP>::length() const
diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/wx+/choice_enum.h 10.24-1/wx+/choice_enum.h
--- 10.24-0/wx+/choice_enum.h 2020-05-17 18:30:59.441499418 -0400
+++ 10.24-1/wx+/choice_enum.h 2020-05-17 18:53:59.893685507 -0400
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
index bd039a4..ba71e47 100644
--- a/freefilesync/debian/patches/series
+++ b/freefilesync/debian/patches/series
@@ -8,3 +8,4 @@ ffs_sftp.patch
ffs_libssh2.patch
ffs_curl.patch
revert_zenju_aggressive_upstreamisms.patch
+ffs_gcc.patch
bgstack15