summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-02-15 15:36:35 -0500
committerB Stack <bgstack15@gmail.com>2020-02-15 15:36:35 -0500
commit6b099831dceebb0905fc91b133567ee416010a74 (patch)
treebf6e5e5c6b3e7a96aa36aeb9a899bb74ff6e17de /freefilesync/debian
parentMerge branch 'mktrayicon-bump' into 'master' (diff)
downloadstackrpms-6b099831dceebb0905fc91b133567ee416010a74.tar.gz
stackrpms-6b099831dceebb0905fc91b133567ee416010a74.tar.bz2
stackrpms-6b099831dceebb0905fc91b133567ee416010a74.zip
WIP: freefilesync initial patches for 10.20
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/patches/ffs_10.20.patch14
-rw-r--r--freefilesync/debian/patches/ffs_allow_parallel_ops.patch12
-rw-r--r--freefilesync/debian/patches/ffs_curl.patch18
-rw-r--r--freefilesync/debian/patches/ffs_devuan_gtk2.patch8
-rw-r--r--freefilesync/debian/patches/ffs_libssh2.patch27
-rw-r--r--freefilesync/debian/patches/ffs_no_check_updates.patch8
-rw-r--r--freefilesync/debian/patches/series1
7 files changed, 66 insertions, 22 deletions
diff --git a/freefilesync/debian/patches/ffs_10.20.patch b/freefilesync/debian/patches/ffs_10.20.patch
new file mode 100644
index 0000000..8369e30
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_10.20.patch
@@ -0,0 +1,14 @@
+Message: To make FreeFileSync 10.20 compile. Looks like some includes were omitted by upstream.
+Date: 2020-02-15 20:00
+diff -Naur /usr/src/freefilesync/10.20-0/FreeFileSync/Source/base/log_file.cpp /usr/src/freefilesync/10.20-1/FreeFileSync/Source/base/log_file.cpp
+--- 10.20-0/FreeFileSync/Source/base/log_file.cpp 2020-02-15 14:50:08.340617412 -0500
++++ 10.20-1/FreeFileSync/Source/base/log_file.cpp 2020-02-15 15:01:36.687166993 -0500
+@@ -9,6 +9,8 @@
+ #include <wx/datetime.h>
+ #include "ffs_paths.h"
+ #include "../afs/concrete.h"
++#include "../../../zen/system.h"
++#include "../../../zen/http.h"
+
+ using namespace zen;
+ using namespace fff;
diff --git a/freefilesync/debian/patches/ffs_allow_parallel_ops.patch b/freefilesync/debian/patches/ffs_allow_parallel_ops.patch
index e464662..3d8197f 100644
--- a/freefilesync/debian/patches/ffs_allow_parallel_ops.patch
+++ b/freefilesync/debian/patches/ffs_allow_parallel_ops.patch
@@ -13,13 +13,13 @@ diff -x '*.orig' -x '*.swp' -x '*.rej' -Naur 10.9-0/FreeFileSync/Source/ui/folde
return;
diff -Naur -x '*.orig' -x '*.rej' 10.9-0/FreeFileSync/Source/ui/sync_cfg.cpp 10.9-1/FreeFileSync/Source/ui/sync_cfg.cpp
--- 10.9-0/FreeFileSync/Source/ui/sync_cfg.cpp 2019-02-10 22:01:42.075159451 -0500
-+++ 10.9-1/FreeFileSync/Source/ui/sync_cfg.cpp 2019-02-11 21:25:11.685992654 -0500
-@@ -263,7 +263,7 @@
++++ 10.20-1/FreeFileSync/Source/ui/sync_cfg.cpp 2019-02-11 21:25:11.685992654 -0500
+@@ -283,7 +283,7 @@
+ commandHistoryOut_(commandHistory),
globalPairCfg_(globalPairCfg),
localPairCfg_(localPairConfig),
- showMultipleCfgs_(showMultipleCfgs),
--perfPanelActive_(false),
-+perfPanelActive_(true),
- commandHistItemsMax_(commandHistItemsMax)
+-enableExtraFeatures_(false),
++enableExtraFeatures_(true),
+ showMultipleCfgs_(showMultipleCfgs)
{
setStandardButtonLayout(*bSizerStdButtons, StdButtons().setAffirmative(m_buttonOkay).setCancel(m_buttonCancel));
diff --git a/freefilesync/debian/patches/ffs_curl.patch b/freefilesync/debian/patches/ffs_curl.patch
index 2844a54..2396648 100644
--- a/freefilesync/debian/patches/ffs_curl.patch
+++ b/freefilesync/debian/patches/ffs_curl.patch
@@ -18,3 +18,21 @@ diff -r -u 10.17-0/FreeFileSync/Source/afs/ftp.cpp 10.17-1/FreeFileSync/Source/a
2. CURLFTPMETHOD_SINGLECWD requires absolute paths to skip one needless "CWD entry path": https://github.com/curl/curl/pull/4332
=> https://curl.haxx.se/docs/faq.html#How_do_I_list_the_root_dir_of_an
+Message: Devuan does not have whichever version of libcurl that provides these error codes, probably 7.68.0. Devuan as of 2020-02-15 has libcurl4-openssl-dev=7.67.0-2
+diff -Naur 10.20-0/libcurl/curl_wrap.h 10.20-1/libcurl/curl_wrap.h
+--- 10.20-0/libcurl/curl_wrap.h 2020-02-15 14:50:08.356617565 -0500
++++ 10.20-1/libcurl/curl_wrap.h 2020-02-15 14:51:55.961645573 -0500
+@@ -135,10 +135,10 @@
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_HTTP2_STREAM);
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_RECURSIVE_API_CALL);
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_AUTH_ERROR);
+- ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_HTTP3);
+- ZEN_CHECK_CASE_FOR_CONSTANT(CURL_LAST);
++ //ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_HTTP3);
++ //ZEN_CHECK_CASE_FOR_CONSTANT(CURL_LAST);
+ }
+- static_assert(CURL_LAST == CURLE_HTTP3 + 1);
++ //static_assert(CURL_LAST == CURLE_HTTP3 + 1);
+
+ return replaceCpy<std::wstring>(L"Curl status %x.", L"%x", numberTo<std::wstring>(static_cast<int>(sc)));
+ }
diff --git a/freefilesync/debian/patches/ffs_devuan_gtk2.patch b/freefilesync/debian/patches/ffs_devuan_gtk2.patch
index 9db9584..1a79546 100644
--- a/freefilesync/debian/patches/ffs_devuan_gtk2.patch
+++ b/freefilesync/debian/patches/ffs_devuan_gtk2.patch
@@ -44,6 +44,14 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
+@@ -84,6 +85,7 @@
+ CPP_FILES+=../../zen/file_io.cpp
+ CPP_FILES+=../../zen/file_traverser.cpp
+ CPP_FILES+=../../zen/http.cpp
++CPP_FILES+=../../zen/system.cpp
+ CPP_FILES+=../../zen/zstring.cpp
+ CPP_FILES+=../../zen/format_unit.cpp
+ CPP_FILES+=../../zen/legacy_compiler.cpp
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/RealTimeSync/Makefile 10.18-1/FreeFileSync/Source/RealTimeSync/Makefile
--- 10.11-0/FreeFileSync/Source/RealTimeSync/Makefile 2019-04-12 08:05:57.000000000 -0400
+++ 10.18-2/FreeFileSync/Source/RealTimeSync/Makefile 2019-11-21 09:46:11.378240094 -0500
diff --git a/freefilesync/debian/patches/ffs_libssh2.patch b/freefilesync/debian/patches/ffs_libssh2.patch
index 0abd660..66c6a88 100644
--- a/freefilesync/debian/patches/ffs_libssh2.patch
+++ b/freefilesync/debian/patches/ffs_libssh2.patch
@@ -22,15 +22,18 @@ Date: 2019-09-17T13:41:23Z
}
return replaceCpy<std::wstring>(L"SSH status %x.", L"%x", numberTo<std::wstring>(sc));
}
-diff -x '*.swp' -x .git -Naur 10.10-0/FreeFileSync/Source/afs/sftp.cpp 10.10-1/FreeFileSync/Source/afs/sftp.cpp
---- 10.10-0/FreeFileSync/Source/afs/sftp.cpp 2019-03-12 08:09:58.465098982 -0400
-+++ 10.17-1/FreeFileSync/Source/afs/sftp.cpp 2019-10-21 08:46:07.562161269 -0400
-@@ -1588,7 +1588,7 @@
- runSftpCommand(login_, L"libssh2_sftp_mkdir", //throw SysError
- [&](const SshSession::Details& sd) //noexcept!
- {
-- return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath), LIBSSH2_SFTP_DEFAULT_MODE);
-+ return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath), LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO);
- //default for newly created directories: 0777 (LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO)
- });
- }
+Message: It appears upstream moved libssh2_wrap, but the above file patches correctly, so we will leave it while adding this new, identical patch.
+diff -Naur /usr/src/freefilesync/10.20-0/libssh2/libssh2_wrap.h /usr/src/freefilesync/10.20-1/libssh2/libssh2_wrap.h
+--- 10.20-0/libssh2/libssh2_wrap.h 2020-02-15 14:50:08.356617565 -0500
++++ 10.20-1/libssh2/libssh2_wrap.h 2020-02-15 15:11:25.992842154 -0500
+@@ -172,8 +172,8 @@
+ ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_ENCRYPT);
+ ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_BAD_SOCKET);
+ ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_KNOWN_HOSTS);
+- ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_CHANNEL_WINDOW_FULL);
+- ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_KEYFILE_AUTH_FAILED);
++ //ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_CHANNEL_WINDOW_FULL);
++ //ZEN_CHECK_CASE_FOR_CONSTANT(LIBSSH2_ERROR_KEYFILE_AUTH_FAILED);
+ }
+ return replaceCpy<std::wstring>(L"SSH status %x.", L"%x", numberTo<std::wstring>(sc));
+ }
diff --git a/freefilesync/debian/patches/ffs_no_check_updates.patch b/freefilesync/debian/patches/ffs_no_check_updates.patch
index eaff5c4..bb54677 100644
--- a/freefilesync/debian/patches/ffs_no_check_updates.patch
+++ b/freefilesync/debian/patches/ffs_no_check_updates.patch
@@ -61,10 +61,10 @@ diff --exclude '*.orig' -Naur 10.14-0/FreeFileSync/Source/ui/version_check.cpp 1
std::string getOnlineVersion(const std::vector<std::pair<std::string, std::string>>& postParams) //throw SysError
{
-- const std::string buffer = sendHttpPost(Zstr("https://api.freefilesync.org/latest_version"), postParams,
-- ffsUpdateCheckUserAgent, nullptr /*caCertFilePath*/, nullptr /*notifyUnbufferedIO*/).readAll(); //throw SysError
-+ const std::string buffer = "";
- return trimCpy(buffer);
+- const std::string response = sendHttpPost(Zstr("https://api.freefilesync.org/latest_version"), postParams,
+- ffsUpdateCheckUserAgent, nullptr /*caCertFilePath*/, nullptr /*notifyUnbufferedIO*/).readAll(); //throw SysError
++ const std::string response = "";
+ return trimCpy(response);
}
@@ -235,13 +235,13 @@
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
index e3ea666..61f9440 100644
--- a/freefilesync/debian/patches/series
+++ b/freefilesync/debian/patches/series
@@ -6,3 +6,4 @@ ffs_no_wx311.patch
ffs_sftp.patch
ffs_libssh2.patch
ffs_curl.patch
+ffs_10.20.patch
bgstack15