summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-03-18 14:19:01 -0400
committerB Stack <bgstack15@gmail.com>2020-03-18 14:19:01 -0400
commit1414e80d503bfe32fae8aad9eb52af32fe58d721 (patch)
tree3ded8403fffdaac2ee3ebcbaf4e9f78cd1223581 /freefilesync/debian
parentWIP: freefilesync 10.21-2+devuan (diff)
downloadstackrpms-1414e80d503bfe32fae8aad9eb52af32fe58d721.tar.gz
stackrpms-1414e80d503bfe32fae8aad9eb52af32fe58d721.tar.bz2
stackrpms-1414e80d503bfe32fae8aad9eb52af32fe58d721.zip
add ability to control -pie from d/r
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/freefilesync.lintian-overrides1
-rw-r--r--freefilesync/debian/patches/ffs_devuan.patch33
-rw-r--r--freefilesync/debian/patches/ffs_devuan_gtk3.patch11
-rwxr-xr-xfreefilesync/debian/rules1
4 files changed, 25 insertions, 21 deletions
diff --git a/freefilesync/debian/freefilesync.lintian-overrides b/freefilesync/debian/freefilesync.lintian-overrides
index e69de29..6c17eb3 100644
--- a/freefilesync/debian/freefilesync.lintian-overrides
+++ b/freefilesync/debian/freefilesync.lintian-overrides
@@ -0,0 +1 @@
+possible-gpl-code-linked-with-openssl
diff --git a/freefilesync/debian/patches/ffs_devuan.patch b/freefilesync/debian/patches/ffs_devuan.patch
index 47491bb..9bd4a2a 100644
--- a/freefilesync/debian/patches/ffs_devuan.patch
+++ b/freefilesync/debian/patches/ffs_devuan.patch
@@ -16,20 +16,21 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/Makefile 10.18-1/FreeFileSync/Source/Makefile
---- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
-+++ 10.18-2/FreeFileSync/Source/Makefile 2019-11-21 09:42:57.408243242 -0500
+--- 10.21-0/FreeFileSync/Source/Makefile 2020-03-18 08:56:08.576066001 -0400
++++ 10.21-1/FreeFileSync/Source/Makefile 2020-03-18 13:08:06.841403687 -0400
@@ -1,10 +1,10 @@
-EXENAME = FreeFileSync_$(shell arch)
+EXENAME = FreeFileSync
-
- CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+
+-CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
++CXXFLAGS += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
+
-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
-
-
++LINKFLAGS += -s `wx-config --libs std, aui --debug=no` -lz -pthread
+
+
CXXFLAGS += `pkg-config --cflags openssl`
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.19-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.19-1/FreeFileSync/Source/ui/small_dlgs.cpp
--- 10.11-0/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 07:56:06.714625467 -0500
@@ -44,19 +45,19 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.19-0/FreeFileSync/Sou
build += utfTo<wxString>(formatTime(formatDateTag, getCompileTime()));
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/RealTimeSync/Makefile 10.18-1/FreeFileSync/Source/RealTimeSync/Makefile
---- 10.18-0/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 11:45:58.241515736 -0500
-+++ 10.20-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 15:41:50.787195378 -0500
+--- 10.21-0/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 08:56:08.624066524 -0400
++++ 10.21-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 13:08:24.409600169 -0400
@@ -1,10 +1,10 @@
-EXENAME = RealTimeSync_$(shell arch)
+EXENAME = RealTimeSync
-
- CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+
+-CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
++CXXFLAGS += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
+
-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
-
++LINKFLAGS += -s `wx-config --libs std, aui --debug=no` -lz -pthread
+
#Gtk - support "no button border"
CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-
diff --git a/freefilesync/debian/patches/ffs_devuan_gtk3.patch b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
index 1f87d9a..4f41d7a 100644
--- a/freefilesync/debian/patches/ffs_devuan_gtk3.patch
+++ b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
@@ -1,7 +1,7 @@
Author: B Stack
Source: Original research
-Date: 2019-11-21
-Message: Main patch to compile on Devuan.
+Date: 2020-03-18
+Message: Main patch to compile on Devuan using GTK3. BROKEN for FreeFileSync 10.21!
This reintroduces the gtk-3 usage, because Debian/Devuan stopped packaging libwxgtk3.0-dev (which used gtk2) and only does libwxgtk3.0-gtk3-dev. However, by reintroducing the gtk3, it brings back the old gtk3 instability from my previous packaging effort: https://freefilesync.org/forum/viewtopic.php?t=4918. /mnt/public/packages/old/freefilesync/freefilesync-9.7-1.master.tgz. Upstream never replied, but did note in the source that gtk3 is inherently unstable.
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/Makefile 10.18-1/FreeFileSync/Source/Makefile
--- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
@@ -19,10 +19,11 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
---- 10.20-0a/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 17:30:56.738835393 -0500
-+++ 10.20-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 19:09:17.460124615 -0500
+diff -x '*.rej' -x '*.swp' -x '*.orig' -Naur 10.21-1/FreeFileSync/Source/RealTimeSync/Makefile 10.21-2/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.21-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 13:12:18.404217783 -0400
++++ 10.21-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 13:12:46.528533268 -0400
@@ -7,9 +7,10 @@
- LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+ LINKFLAGS += -s `wx-config --libs std, aui --debug=no` -lz -pthread
#Gtk - support "no button border"
-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
diff --git a/freefilesync/debian/rules b/freefilesync/debian/rules
index b33b50b..6f439e4 100755
--- a/freefilesync/debian/rules
+++ b/freefilesync/debian/rules
@@ -4,6 +4,7 @@
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export LINKFLAGS="${LDFLAGS} -pie"
export appname=freefilesync
export pkgname=FreeFileSync
bgstack15