summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-03-13 15:11:55 +0000
committerB Stack <bgstack15@gmail.com>2019-03-13 15:11:55 +0000
commit857ce57484e723430b2fd64a8f05637c48696fbc (patch)
treeec01f6b1b4e944f8d945f5557e70101e43a26888 /freefilesync/debian
parentMerge branch 'move-dpkg' into 'master' (diff)
downloadstackrpms-857ce57484e723430b2fd64a8f05637c48696fbc.tar.gz
stackrpms-857ce57484e723430b2fd64a8f05637c48696fbc.tar.bz2
stackrpms-857ce57484e723430b2fd64a8f05637c48696fbc.zip
Freefilesync 10.10
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/changelog22
-rw-r--r--freefilesync/debian/patches/ffs_libssh2.patch21
-rw-r--r--freefilesync/debian/patches/series1
3 files changed, 44 insertions, 0 deletions
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index 914b53d..be9ca15 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,25 @@
+freefilesync (10.10-1devuan) manual; urgency=low
+
+ * New option: synchronize selection
+ * Dynamically disable unsuitable context menu options
+ * Support MTP devices without move command
+ * Fall back to copy/delete when implicitly moving to different device (e.g. symlink)
+ * Fixed incorrect statistics after parallel move
+ * Fixed menu button not triggering context menu
+ * Fixed crash on focus change while message popup is dismissed
+ * Fixed crash when trying to shrink empty image
+ * Fixed invisible dialogs when monitor is turned off in multi-monitor setup
+ * Work around GetFileInformationByHandle error code 58 on WD My Cloud EX
+ * Changing deletion handling now correctly triggers updated config
+ * Support root-relative FTP file paths (e.g. FreeNAS)
+ * Move and rename MTP items as a transaction
+ * Exclude AppleDouble files (._) via default filter on macOS
+ * Support home path for FTP folder picker
+ * Use server default permissions when creating SFTP folder
+ * Use native OpenSSL AES-CTR rather than libssh2 fallback
+ * Added context information for cloud connection errors
+ * Updated translation files
+
freefilesync (10.9-1devuan) manual; urgency=low
* Added FTP, SFTP, Google Drive support for Linux
diff --git a/freefilesync/debian/patches/ffs_libssh2.patch b/freefilesync/debian/patches/ffs_libssh2.patch
new file mode 100644
index 0000000..81287a3
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_libssh2.patch
@@ -0,0 +1,21 @@
+Source: https://aur.archlinux.org/cgit/aur.git/commit/?h=freefilesync&id=7e1524db8e0243ff9d7b7dcba64a3a5228295725
+Author: Simon Brulhart
+Message: libssh2 v1.8.0 does not yet implement LIBSSH2_SFTP_DEFAULT_MODE, revert to previous impl.
+Method:
+
+ sed -e 's/LIBSSH2_SFTP_DEFAULT_MODE/LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO/g' -i 'FreeFileSync/Source/fs/sftp.cpp'
+
+diff -x '*.swp' -x .git -Naur 10.10-0/FreeFileSync/Source/fs/sftp.cpp 10.10-1/FreeFileSync/Source/fs/sftp.cpp
+--- 10.10-0/FreeFileSync/Source/fs/sftp.cpp 2019-03-12 08:09:58.465098982 -0400
++++ 10.10-1/FreeFileSync/Source/fs/sftp.cpp 2019-03-12 08:27:05.718963710 -0400
+@@ -1657,8 +1657,8 @@
+ runSftpCommand(login_, L"libssh2_sftp_mkdir", //throw SysError
+ [&](const SshSession::Details& sd) //noexcept!
+ {
+-#if 1 //let's see how LIBSSH2_SFTP_DEFAULT_MODE works out:
+- return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_DEFAULT_MODE);
++#if 1 //let's see how LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO works out:
++ return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO);
+ #else //default for newly created directories: 0777
+ return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO);
+ #endif
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
index 2dbed63..dcbf30c 100644
--- a/freefilesync/debian/patches/series
+++ b/freefilesync/debian/patches/series
@@ -5,3 +5,4 @@ ffs_no_check_updates.patch
ffs_no_wx311.patch
ffs_old_libcurl.patch
ffs_sftp.patch
+ffs_libssh2.patch
bgstack15