summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2021-01-04 08:43:21 -0500
committerB Stack <bgstack15@gmail.com>2021-01-04 08:43:21 -0500
commitf7491e9d517e16973ab33f80789c9964d764a361 (patch)
tree595d578b18ca05f1da2fe167ba1e8ef5796ebb3e /freefilesync/debian
parentMerge branch 'palemoon-bump' into 'master' (diff)
downloadstackrpms-f7491e9d517e16973ab33f80789c9964d764a361.tar.gz
stackrpms-f7491e9d517e16973ab33f80789c9964d764a361.tar.bz2
stackrpms-f7491e9d517e16973ab33f80789c9964d764a361.zip
ffs 11.5-1 rc1
The patches only needed fixes for fuzz, and not any refactoring!
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/changelog22
-rw-r--r--freefilesync/debian/freefilesync+devuan.dsc2
-rw-r--r--freefilesync/debian/patches/ffs_traditional_view.patch8
-rw-r--r--freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch6
4 files changed, 30 insertions, 8 deletions
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index 32166cd..75dd001 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,25 @@
+freefilesync (11.5-1+devuan) obs; urgency=medium
+
+ * Upstream updates
+ - New configuration context menu option to delete from disk
+ - Start auto retry delay at time of error instead of reporting
+ - Added error details to status message before retry
+ - Improved color scheme to better integrate with system colors
+ - Keep partial SFTP results after network failure
+ - Fixed incorrect panel font (macOS Big Sur)
+ - Fixed SFTP retry not working after network drop
+ - Fixed crash on exit with floating panels (macOS Big Sur)
+ - Fixed auto-close option not being remembered
+ - Fixed installer high-DPI scaling issues
+ - Fixed mouse hover issues with grid column header
+ - Fixed menu bar icons not showing (Linux)
+ - Removed redundant GUI layout recalculations
+ - Keep correct panel sizes after log panel maximize
+ - Support modern folder picker in installer
+ - Don't raise progress dialog after sync when resuming from systray
+
+ -- B. Stack <bgstack15@gmail.com> Mon, 04 Jan 2021 08:40:35 -0500
+
freefilesync (11.4-1+devuan) obs; urgency=medium
* Upstream updates
diff --git a/freefilesync/debian/freefilesync+devuan.dsc b/freefilesync/debian/freefilesync+devuan.dsc
index 8ba45f2..46daffe 100644
--- a/freefilesync/debian/freefilesync+devuan.dsc
+++ b/freefilesync/debian/freefilesync+devuan.dsc
@@ -2,7 +2,7 @@ Format: 3.0 (quilt)
Source: freefilesync
Binary: freefilesync
Architecture: any
-Version: 11.4-1+devuan
+Version: 11.5-1+devuan
Maintainer: B Stack <bgstack15@gmail.com>
Homepage: https://freefilesync.org/
Standards-Version: 4.1.4
diff --git a/freefilesync/debian/patches/ffs_traditional_view.patch b/freefilesync/debian/patches/ffs_traditional_view.patch
index c075820..e5c4a14 100644
--- a/freefilesync/debian/patches/ffs_traditional_view.patch
+++ b/freefilesync/debian/patches/ffs_traditional_view.patch
@@ -1,5 +1,5 @@
-Version: 11.4
-Date: 2020-12-08
+Version: 11.5
+Date: 2021-01-04
Author: bgstack15@gmail.com
Message: restore a traditional view to FreeFileSync
diff -x '*.orig' -x '*.rej' -aur 11.3-0/FreeFileSync/Source/ui/file_grid.cpp 11.3-1/FreeFileSync/Source/ui/file_grid.cpp
@@ -158,7 +158,7 @@ diff -x '*.orig' -x '*.rej' -aur 11.3-0/FreeFileSync/Source/ui/file_grid.cpp 11.
clearArea(dc, rectGroupBack, getDefaultBackgroundColorAlternating(pdi.groupIdx % 2 == 0));
//clearArea() is surprisingly expensive => call just once!
-@@ -922,7 +989,8 @@
+@@ -924,7 +991,8 @@
rectNav.width = fastFromDIP(20);
if (row == pdi.groupLastRow - 1 /*last group item*/) //preserve the group separation line!
@@ -166,7 +166,7 @@ diff -x '*.orig' -x '*.rej' -aur 11.3-0/FreeFileSync/Source/ui/file_grid.cpp 11.
+ if (itemPathFormat_ != ItemPathFormat::traditional && itemPathFormat_ != ItemPathFormat::tradrel)
+ rectNav.height -= lineWidth;
- wxColor backCol = *wxWHITE;
+ wxColor backCol = wxSystemSettings::GetColour(wxSYS_COLOUR_WINDOW);
dc.GetPixel(rectNav.GetTopRight(), &backCol); //e.g. selected row!
@@ -930,11 +998,11 @@
dc.GradientFillLinear(rectNav, getColorSelectionGradientFrom(), backCol, wxEAST);
diff --git a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
index ad3f51e..9492e33 100644
--- a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
+++ b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
@@ -156,11 +156,11 @@ diff -x '*.orig' -x '*.rej' -aur 11.1-1/wx+/bitmap_button.h 11.1-2/wx+/bitmap_bu
{
SetLabel(label);
diff -x '*.orig' -x '*.rej' -aur 11.1-1/wx+/dc.h 11.1-2/wx+/dc.h
---- 11.1-1/wx+/dc.h 2020-09-01 19:09:33.652448178 -0400
-+++ 11.1-2/wx+/dc.h 2020-09-01 20:08:43.183988180 -0400
+--- 11.5-0/wx+/dc.h 2021-01-04 08:07:48.384544469 -0500
++++ 11.5-1/wx+/dc.h 2021-01-04 08:13:41.316314485 -0500
@@ -68,9 +68,6 @@
inline
- int fastFromDIP(int d) //like wxWindow::FromDIP (but tied to primary monitor and buffered)
+ int fastFromDIP(double d) //like wxWindow::FromDIP (but tied to primary monitor and buffered)
{
-#ifndef wxHAVE_DPI_INDEPENDENT_PIXELS
-#error why is wxHAVE_DPI_INDEPENDENT_PIXELS not defined?
bgstack15