summaryrefslogtreecommitdiff
path: root/freefilesync/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-11-02 22:15:04 +0000
committerB Stack <bgstack15@gmail.com>2020-11-02 22:15:04 +0000
commitdebb37f9bef003546343a85573137daf7524b5a1 (patch)
tree53811457126253c74fb638abd1bf2253094bc3dd /freefilesync/debian/rules
parentMerge branch 'waterfox-bump' into 'master' (diff)
parentffs 11.3-1 (diff)
downloadstackrpms-debb37f9bef003546343a85573137daf7524b5a1.tar.gz
stackrpms-debb37f9bef003546343a85573137daf7524b5a1.tar.bz2
stackrpms-debb37f9bef003546343a85573137daf7524b5a1.zip
Merge branch 'freefilesync-bump' into 'master'
FreeFileSync 11.3-1 See merge request bgstack15/stackrpms!201
Diffstat (limited to 'freefilesync/debian/rules')
-rwxr-xr-xfreefilesync/debian/rules26
1 files changed, 13 insertions, 13 deletions
diff --git a/freefilesync/debian/rules b/freefilesync/debian/rules
index a359bd9..2d49df4 100755
--- a/freefilesync/debian/rules
+++ b/freefilesync/debian/rules
@@ -24,7 +24,7 @@ override_dh_auto_clean:
dh_auto_clean
dh_auto_clean --sourcedirectory=FreeFileSync/Source
dh_auto_clean --sourcedirectory=FreeFileSync/Source/RealTimeSync
- rm -f ${pkgname}.png ${prog2name}.png file_batch.png
+ rm -f ${pkgname}.png ${prog2name}.png cfg_batch.png
override_dh_auto_build:
dh_auto_build
@@ -56,7 +56,7 @@ override_dh_auto_install:
# handled by dpkg already
# icons
- unzip ${pkgname}/Build/Resources/Icons.zip file_batch.png file_sync.png
+ unzip ${pkgname}/Build/Resources/Icons.zip cfg_batch.png start_sync.png
mkdir -p ${buildroot}${_datadir}/icons/hicolor/16x16/apps
mkdir -p ${buildroot}${_datadir}/icons/hicolor/32x32/apps
mkdir -p ${buildroot}${_datadir}/icons/hicolor/48x48/apps
@@ -79,23 +79,23 @@ override_dh_auto_install:
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/apps/${prog2name}.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/apps/${prog2name}.png
# mimetypes
- convert file_batch.png -filter Lanczos -resize 16x16 ${buildroot}${_datadir}/icons/hicolor/16x16/mimetypes/application-x-freefilesync-batch.png
- convert file_batch.png -filter Lanczos -resize 32x32 ${buildroot}${_datadir}/icons/hicolor/32x32/mimetypes/application-x-freefilesync-batch.png
- convert file_batch.png -filter Lanczos -resize 48x48 ${buildroot}${_datadir}/icons/hicolor/48x48/mimetypes/application-x-freefilesync-batch.png
- convert file_batch.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/mimetypes/application-x-freefilesync-batch.png
- convert file_batch.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-batch.png
- convert file_sync.png -filter Lanczos -resize 16x16 ${buildroot}${_datadir}/icons/hicolor/16x16/mimetypes/application-x-freefilesync-ffs.png
- convert file_sync.png -filter Lanczos -resize 32x32 ${buildroot}${_datadir}/icons/hicolor/32x32/mimetypes/application-x-freefilesync-ffs.png
- convert file_sync.png -filter Lanczos -resize 48x48 ${buildroot}${_datadir}/icons/hicolor/48x48/mimetypes/application-x-freefilesync-ffs.png
- convert file_sync.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/mimetypes/application-x-freefilesync-ffs.png
- convert file_sync.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-ffs.png
+ convert cfg_batch.png -filter Lanczos -resize 16x16 ${buildroot}${_datadir}/icons/hicolor/16x16/mimetypes/application-x-freefilesync-batch.png
+ convert cfg_batch.png -filter Lanczos -resize 32x32 ${buildroot}${_datadir}/icons/hicolor/32x32/mimetypes/application-x-freefilesync-batch.png
+ convert cfg_batch.png -filter Lanczos -resize 48x48 ${buildroot}${_datadir}/icons/hicolor/48x48/mimetypes/application-x-freefilesync-batch.png
+ convert cfg_batch.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/mimetypes/application-x-freefilesync-batch.png
+ convert cfg_batch.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-batch.png
+ convert start_sync.png -filter Lanczos -resize 16x16 ${buildroot}${_datadir}/icons/hicolor/16x16/mimetypes/application-x-freefilesync-ffs.png
+ convert start_sync.png -filter Lanczos -resize 32x32 ${buildroot}${_datadir}/icons/hicolor/32x32/mimetypes/application-x-freefilesync-ffs.png
+ convert start_sync.png -filter Lanczos -resize 48x48 ${buildroot}${_datadir}/icons/hicolor/48x48/mimetypes/application-x-freefilesync-ffs.png
+ convert start_sync.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/mimetypes/application-x-freefilesync-ffs.png
+ convert start_sync.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-ffs.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 16x16 ${buildroot}${_datadir}/icons/hicolor/16x16/mimetypes/application-x-freefilesync-real.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 32x32 ${buildroot}${_datadir}/icons/hicolor/32x32/mimetypes/application-x-freefilesync-real.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 48x48 ${buildroot}${_datadir}/icons/hicolor/48x48/mimetypes/application-x-freefilesync-real.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 64x64 ${buildroot}${_datadir}/icons/hicolor/64x64/mimetypes/application-x-freefilesync-real.png
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-real.png
- rm -f file_batch.png file_sync.png
+ rm -f cfg_batch.png start_sync.png
override_dh_fixperms:
dh_fixperms || :
bgstack15