summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-01-30 15:42:32 -0500
committerB Stack <bgstack15@gmail.com>2019-01-30 15:42:32 -0500
commit8f72976db1311f5de6d4916f4db0058346e0f727 (patch)
tree47b224ccd882ec12a932ad77732704ea082eed65 /freefilesync/debian/patches
parentadd palemoon dpkg for devuan (diff)
downloadstackrpms-8f72976db1311f5de6d4916f4db0058346e0f727.tar.gz
stackrpms-8f72976db1311f5de6d4916f4db0058346e0f727.tar.bz2
stackrpms-8f72976db1311f5de6d4916f4db0058346e0f727.zip
add freefilesync dpkg rough draft
Diffstat (limited to 'freefilesync/debian/patches')
-rw-r--r--freefilesync/debian/patches/devuan.patch24
-rw-r--r--freefilesync/debian/patches/makefile.patch32
-rw-r--r--freefilesync/debian/patches/no_check_updates.patch57
-rw-r--r--freefilesync/debian/patches/no_wx311.patch44
-rw-r--r--freefilesync/debian/patches/series5
5 files changed, 162 insertions, 0 deletions
diff --git a/freefilesync/debian/patches/devuan.patch b/freefilesync/debian/patches/devuan.patch
new file mode 100644
index 0000000..abe5389
--- /dev/null
+++ b/freefilesync/debian/patches/devuan.patch
@@ -0,0 +1,24 @@
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp
+--- 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-07 05:03:34.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-29 22:13:40.240595334 -0400
+@@ -106,6 +106,8 @@
+ L" x64";
+ #endif
+
++ build +=
++ L" for Devuan";
+
+ GetSizer()->SetSizeHints(this); //~=Fit() + SetMinSize()
+
+diff -Naur 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp
+--- 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-13 06:58:40.771249592 -0500
++++ 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-16 21:34:30.341077845 -0500
+@@ -66,7 +66,7 @@
+ ZEN_ON_SCOPE_EXIT(wxTheApp->SetAppName(appName));
+
+ //if (isPortableVersion())
+- return appendSeparator(getExeFolderParentPath());
++ return appendSeparator(getExeFolderParentPath()) + appendSeparator("share") + appendSeparator("FreeFileSync");
+ //else //use OS' standard paths
+ // return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
+ }
diff --git a/freefilesync/debian/patches/makefile.patch b/freefilesync/debian/patches/makefile.patch
new file mode 100644
index 0000000..b3ff7ff
--- /dev/null
+++ b/freefilesync/debian/patches/makefile.patch
@@ -0,0 +1,32 @@
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/Makefile 10.3-2/FreeFileSync/Source/Makefile
+--- 10.3-0/FreeFileSync/Source/Makefile 2018-08-07 05:03:33.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/Makefile 2018-08-15 22:25:06.694355202 -0400
+@@ -9,7 +9,7 @@
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+ #Gtk - support recycler/icon loading/no button border/grid scrolling
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
+@@ -101,6 +101,7 @@
+ all: ../Build/Bin/$(APPNAME)
+
+ ../Build/Bin/$(APPNAME): $(OBJ_FILES)
++ mkdir -p ../Build/Bin
+ g++ -o $@ $^ $(LINKFLAGS)
+
+ ../Obj/FFS_GCC_Make_Release/ffs/src/%.o : %
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/RealTimeSync/Makefile 10.3-2/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.3-0/FreeFileSync/Source/RealTimeSync/Makefile 2018-08-07 05:03:33.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/RealTimeSync/Makefile 2018-08-15 22:25:15.968461418 -0400
+@@ -6,7 +6,7 @@
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+ #Gtk - support "no button border"
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
diff --git a/freefilesync/debian/patches/no_check_updates.patch b/freefilesync/debian/patches/no_check_updates.patch
new file mode 100644
index 0000000..99f0c8f
--- /dev/null
+++ b/freefilesync/debian/patches/no_check_updates.patch
@@ -0,0 +1,57 @@
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/ui/main_dlg.cpp 10.3-2/FreeFileSync/Source/ui/main_dlg.cpp
+--- 10.3-0/FreeFileSync/Source/ui/main_dlg.cpp 2018-08-07 05:03:34.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/ui/main_dlg.cpp 2018-08-08 18:50:50.455078387 -0400
+@@ -5004,7 +5004,7 @@
+ globalCfg_.gui.lastUpdateCheck = 0; //reset to GlobalSettings.xml default value!
+
+ m_menuItemCheckVersionAuto->Check(updateCheckActive(globalCfg_.gui.lastUpdateCheck));
+-
++ /*
+ if (shouldRunAutomaticUpdateCheck(globalCfg_.gui.lastUpdateCheck))
+ {
+ flashStatusInformation(_("Searching for program updates..."));
+@@ -5012,6 +5012,7 @@
+ automaticUpdateCheckEval(this, globalCfg_.gui.lastUpdateCheck, globalCfg_.gui.lastOnlineVersion,
+ automaticUpdateCheckRunAsync(automaticUpdateCheckPrepare().get()).get());
+ }
++ */
+ }
+
+
+@@ -5019,7 +5020,7 @@
+ {
+ //execute just once per startup!
+ Disconnect(wxEVT_IDLE, wxIdleEventHandler(MainDialog::OnRegularUpdateCheck), nullptr, this);
+-
++ /*
+ if (shouldRunAutomaticUpdateCheck(globalCfg_.gui.lastUpdateCheck))
+ {
+ flashStatusInformation(_("Searching for program updates..."));
+@@ -5033,6 +5034,7 @@
+ resultAsync.get()); //run on main thread:
+ });
+ }
++ */
+ }
+
+
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/ui/version_check_impl.h 10.3-2/FreeFileSync/Source/ui/version_check_impl.h
+--- 10.3-0/FreeFileSync/Source/ui/version_check_impl.h 2018-08-07 05:03:34.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/ui/version_check_impl.h 2018-08-08 18:50:50.458078415 -0400
+@@ -14,7 +14,7 @@
+
+ namespace fff
+ {
+-inline
++
+ time_t getVersionCheckInactiveId()
+ {
+ //use current version to calculate a changing number for the inactive state near UTC begin, in order to always check for updates after installing a new version
+@@ -38,7 +38,6 @@
+ }
+
+
+-inline
+ time_t getVersionCheckCurrentTime()
+ {
+ return std::time(nullptr);
diff --git a/freefilesync/debian/patches/no_wx311.patch b/freefilesync/debian/patches/no_wx311.patch
new file mode 100644
index 0000000..78ac2a5
--- /dev/null
+++ b/freefilesync/debian/patches/no_wx311.patch
@@ -0,0 +1,44 @@
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp
+--- 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-07 05:03:34.000000000 -0400
++++ 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-08 19:16:54.026727623 -0400
+@@ -984,7 +984,8 @@
+ //setMainInstructionFont(*m_staticTextMain);
+
+ m_bitmapActivation->SetBitmap(getResourceImage(L"website"));
+- m_textCtrlOfflineActivationKey->ForceUpper();
++ // Fedora 27 does not have wxWidgets 3.1.1 yet. https://github.com/wxWidgets/wxWidgets/commit/69b66e9e2e2b8e49e3816acdde079686ce9b0da1
++ //m_textCtrlOfflineActivationKey->ForceUpper();
+
+ m_textCtrlLastError ->ChangeValue(lastErrorMsg);
+ m_textCtrlManualActivationUrl ->ChangeValue(manualActivationUrl);
+diff -Naur -x '*.orig' -x '*.rej' 10.3-0/wx+/grid.cpp 10.3-2/wx+/grid.cpp
+--- 10.3-0/wx+/grid.cpp 2018-08-07 05:03:34.000000000 -0400
++++ 10.3-2/wx+/grid.cpp 2018-08-08 19:24:56.849445102 -0400
+@@ -1176,7 +1176,9 @@
+ {
+ if (overlapPix != 0)
+ {
+- const double scrollSpeed = wnd_.ToDIP(overlapPix) * mouseDragSpeedIncScrollU; //unit: [scroll units / sec]
++ // Fedora 28 does not have wxGTK 3.1.1 yet. This probably breaks HiDPI usage
++ //const double scrollSpeed = wnd_.ToDIP(overlapPix) * mouseDragSpeedIncScrollU; //unit: [scroll units / sec]
++ const double scrollSpeed = overlapPix * mouseDragSpeedIncScrollU; //unit: [scroll units / sec]
+ toScroll += scrollSpeed * deltaSecs;
+ }
+ else
+diff -Naur 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp
+--- 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-13 06:58:40.771249592 -0500
++++ 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-14 21:39:14.715702415 -0500
+@@ -85,8 +85,11 @@
+ else //OS standard path (XDG layout): ~/.config/FreeFileSync
+ {
+ //wxBug: wxStandardPaths::GetUserDataDir() does not honor FileLayout_XDG flag
+- wxStandardPaths::Get().SetFileLayout(wxStandardPaths::FileLayout_XDG);
+- cfgFolderPath = appendSeparator(utfTo<Zstring>(wxStandardPaths::Get().GetUserConfigDir())) + "FreeFileSync";
++
++ // Fedora 28 does not have wxGTK 3.1.1 yet.
++ // So subsitute a hard-coded name instead of requesting file layout of XDG
++ //wxStandardPaths::Get().SetFileLayout(wxStandardPaths::FileLayout_XDG);
++ cfgFolderPath = appendSeparator(utfTo<Zstring>(wxStandardPaths::Get().GetUserConfigDir())) + appendSeparator(utfTo<Zstring>(".config")) + "FreeFileSync";
+ }
+
+ #ifdef __GNUC__
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
new file mode 100644
index 0000000..d430762
--- /dev/null
+++ b/freefilesync/debian/patches/series
@@ -0,0 +1,5 @@
+# You must remove unused comment lines for the released package.
+no_check_updates.patch
+devuan.patch
+no_wx311.patch
+makefile.patch
bgstack15