summaryrefslogtreecommitdiff
path: root/chicago95/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-09-10 23:10:44 -0400
committerB Stack <bgstack15@gmail.com>2019-09-10 23:10:44 -0400
commit0313a4089306caedfdc001644a4b4ec76cb2d31a (patch)
tree5ebfa4c55347bd7cc8ce35e118b5f42a2670d43e /chicago95/debian/rules
parentMerge branch 'mot-bump' into 'master' (diff)
downloadstackrpms-0313a4089306caedfdc001644a4b4ec76cb2d31a.tar.gz
stackrpms-0313a4089306caedfdc001644a4b4ec76cb2d31a.tar.bz2
stackrpms-0313a4089306caedfdc001644a4b4ec76cb2d31a.zip
initial commit
Baseline child packages are tested, minus plymouth and greeter; Plymouth is not packaged for devuan (banned because of systemd) and greeter depends on lightdm-webkit-greeter which I need to build.
Diffstat (limited to 'chicago95/debian/rules')
-rwxr-xr-xchicago95/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/chicago95/debian/rules b/chicago95/debian/rules
new file mode 100755
index 0000000..bc6662c
--- /dev/null
+++ b/chicago95/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export debuilddir="debian"
+export buildroot="${debuilddir}/${appname}"
+export _datadir="/usr/share"
+export _bindir="/usr/bin"
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install
+
+ install -m0755 -d ${buildroot}${_datadir}/sounds/Chicago95
+ install -m0644 "Extras/Microsoft Windows 95 Startup Sound.ogg" ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+
+override_dh_auto_clean:
+ rm -f ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+ dh_auto_clean
bgstack15