summaryrefslogtreecommitdiff
path: root/chicago95/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-09-13 18:03:17 +0000
committerB Stack <bgstack15@gmail.com>2019-09-13 18:03:17 +0000
commitd3887a744a54fa1c87078396fbfe294e4b4fdc47 (patch)
treef16a8420d30c5ebd58daa69b04402dda409f50ba /chicago95/debian/rules
parentMerge branch 'palemoon-bump' into 'master' (diff)
parentBetter documentation for chicago95 (diff)
downloadstackrpms-d3887a744a54fa1c87078396fbfe294e4b4fdc47.tar.gz
stackrpms-d3887a744a54fa1c87078396fbfe294e4b4fdc47.tar.bz2
stackrpms-d3887a744a54fa1c87078396fbfe294e4b4fdc47.zip
Merge branch 'chicago95-bump' into 'master'
Chicago95 dpkg scripts See merge request bgstack15/stackrpms!86
Diffstat (limited to 'chicago95/debian/rules')
-rwxr-xr-xchicago95/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/chicago95/debian/rules b/chicago95/debian/rules
new file mode 100755
index 0000000..bc6662c
--- /dev/null
+++ b/chicago95/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export debuilddir="debian"
+export buildroot="${debuilddir}/${appname}"
+export _datadir="/usr/share"
+export _bindir="/usr/bin"
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install
+
+ install -m0755 -d ${buildroot}${_datadir}/sounds/Chicago95
+ install -m0644 "Extras/Microsoft Windows 95 Startup Sound.ogg" ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+
+override_dh_auto_clean:
+ rm -f ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+ dh_auto_clean
bgstack15