summaryrefslogtreecommitdiff
path: root/ccextractor/ccextractor.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-04-21 20:22:14 +0000
committerB Stack <bgstack15@gmail.com>2019-04-21 20:22:14 +0000
commit4bca5327192eb339e0a4c9550d7fc3446be91306 (patch)
treeec8ae93b24275719a32502c54b5839bc97a3dc7b /ccextractor/ccextractor.spec
parentMerge branch 'waterfox-rpm' into 'master' (diff)
downloadstackrpms-4bca5327192eb339e0a4c9550d7fc3446be91306.tar.gz
stackrpms-4bca5327192eb339e0a4c9550d7fc3446be91306.tar.bz2
stackrpms-4bca5327192eb339e0a4c9550d7fc3446be91306.zip
add makemkv and ccextractor
Diffstat (limited to 'ccextractor/ccextractor.spec')
-rw-r--r--ccextractor/ccextractor.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/ccextractor/ccextractor.spec b/ccextractor/ccextractor.spec
new file mode 100644
index 0000000..bbe1010
--- /dev/null
+++ b/ccextractor/ccextractor.spec
@@ -0,0 +1,67 @@
+Name: ccextractor
+Version: 0.87
+Release: 10%{?dist}
+Summary: A closed captions and teletext subtitles extractor for video streams.
+License: GPL
+URL: http://ccextractor.org/
+
+Source0: https://github.com/CCExtractor/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
+
+Patch0: %{name}-%{version}-system-libraries-and-cflags.patch
+
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: gcc
+BuildRequires: freetype-devel
+BuildRequires: libpng-devel
+BuildRequires: pkgconfig(glew)
+BuildRequires: pkgconfig(glfw3)
+BuildRequires: pkgconfig(lept)
+BuildRequires: pkgconfig(libavcodec)
+BuildRequires: pkgconfig(libavformat)
+BuildRequires: pkgconfig(libavutil)
+BuildRequires: pkgconfig(libswscale)
+BuildRequires: pkgconfig(tesseract)
+BuildRequires: utf8proc-devel
+BuildRequires: zlib-devel
+
+# Unbundle!
+Provides: bundled(gpac)
+Provides: bundled(protobuf-c)
+Provides: bundled(zvbi)
+
+%description
+CCExtractor is a tool used to produce subtitles for TV recordings from almost
+anywhere in the world. We intend to keep up with all sources and formats.
+
+%prep
+%autosetup -p1
+rm -fr src/{freetype,libpng,utf8proc,zlib}
+
+%build
+cd linux
+./pre-build.sh
+
+autoreconf -vif
+
+export CFLAGS="%{optflags} -Wno-maybe-uninitialized"
+%configure \
+ --enable-ffmpeg \
+ --enable-hardsubx \
+ --enable-ocr
+
+%make_build
+
+%install
+cd linux
+%make_install
+
+%files
+%{_bindir}/%{name}
+
+%changelog
+* Wed Apr 03 2019 Simone Caronni <negativo17@gmail.com> - 0.87-2
+- Use system libraries.
+
+* Tue Jan 15 2019 Simone Caronni <negativo17@gmail.com> - 0.87-1
+- First build.
bgstack15