aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGordon Norman Squash <gordsqsh@protonmail.com>2021-02-24 19:40:32 -0500
committerGordon Norman Squash <gordsqsh@protonmail.com>2021-02-24 19:40:32 -0500
commit3479c04fab5de86bd175e8b501c7d1dc3a92d975 (patch)
tree59def9fd219db0a06cefebcc474d3499d5ce1fdb /meson.build
downloadsgm-3479c04fab5de86bd175e8b501c7d1dc3a92d975.tar.gz
sgm-3479c04fab5de86bd175e8b501c7d1dc3a92d975.tar.bz2
sgm-3479c04fab5de86bd175e8b501c7d1dc3a92d975.zip
First commit to STLWRT-ian GTK Modules repository
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..291f0b0
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,33 @@
+project('sgm', 'c',
+ version : '0.90.0',
+ default_options : ['warning_level=3'],
+ license: 'LGPLv2.1+')
+
+
+gtk_dep = dependency('gtk+-3.0', version: '>= 3.8.0')
+
+modules_subdir = 'gtk-3.0/modules'
+modules_install_dir = join_paths(gtk_dep.get_variable(
+ pkgconfig: 'libdir',
+ internal: 'libdir',
+ default_value: get_option('libdir')), modules_subdir)
+
+
+# Don't enable this until the module is ready to go.
+#shared_module('sgm-overlay-scrolling-override',
+# sources: [
+# 'sgm-overlay-scrolling-override.c',
+# ],
+# dependencies: [ gtk_dep ],
+# install_dir: modules_install_dir,
+# install: true,
+#)
+
+shared_module('sgm-flexible-mnemonics',
+ sources: [
+ 'sgm-flexible-mnemonics.c',
+ ],
+ dependencies: [ gtk_dep ],
+ install_dir: modules_install_dir,
+ install: true,
+)
bgstack15