aboutsummaryrefslogtreecommitdiff
path: root/infcloud.spec
diff options
context:
space:
mode:
Diffstat (limited to 'infcloud.spec')
-rw-r--r--infcloud.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/infcloud.spec b/infcloud.spec
new file mode 100644
index 0000000..d7e8b27
--- /dev/null
+++ b/infcloud.spec
@@ -0,0 +1,43 @@
+%define branch stackrpms
+%define pname RadicaleInfCloud
+Name: infcloud
+Version: 0.13.1
+Release: 1%{?dist}
+Summary: Rich web client for carddav and caldav
+BuildArch: noarch
+
+License: AGPL 3.0
+URL: https://Unrud/RadicaleInfCloud
+Source0: https://gitlab.com/bgstack15/%{pname}/-/archive/%{branch}/%{pname}-%{branch}.tar.gz
+
+BuildRequires: python3
+Requires: python3
+
+%description
+This is the RadicaleInfCloud fork of InfCloud, a
+web-based carddav+caldav client. This includes stackrpms
+customizations. Use at your own risk!
+
+%prep
+%setup -q -n %{pname}-%{branch}
+
+%build
+
+%install
+%{__install} --directory -m0755 \
+ %{buildroot}%{_datadir}/%{name} \
+ %{buildroot}%{_sysconfdir}/%{name} \
+ %{buildroot}%{_sbindir}
+%{__cp} -pr * %{buildroot}%{_datadir}/%{name}
+mv %{buildroot}%{_datadir}/%{name}/radicale_infcloud/web/config.js %{buildroot}%{_sysconfdir}/%{name}/
+%{__install} -m0755 update-infcloud-cache %{buildroot}%{_sbindir}/update-infcloud-cache
+ln -s %{_sysconfdir}/%{name}/config.js %{buildroot}%{_datadir}/%{name}/radicale_infcloud/web/config.js
+
+%files
+%{_datadir}/%{name}
+%{_sysconfdir}/%{name}
+%doc README-stackrpms.md
+
+%changelog
+* Tue May 17 2022 B. Stack <bgstack15@gmail.com> - 0.13.1-1
+- Initial rpm built
bgstack15