aboutsummaryrefslogtreecommitdiff
path: root/port-files/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'port-files/debian/rules')
-rwxr-xr-xport-files/debian/rules22
1 files changed, 17 insertions, 5 deletions
diff --git a/port-files/debian/rules b/port-files/debian/rules
index 1617c45e..2840aa2f 100755
--- a/port-files/debian/rules
+++ b/port-files/debian/rules
@@ -6,9 +6,25 @@ include /usr/share/dpkg/default.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#
+# you may want to comment-out --parallel if build breaks for
+# no visible reason or without meaningful error message
+#
+
%:
dh $@ --parallel
+# For Debian GNU/Linux which does not offer manually compiled
+# libxcb-xinput0/libxcb-xinput0-dev, add the following flag:
+#
+# CONFIG+=NO_XINPUT
+#
+# also remove
+#
+# libxcb-xinput0-dev
+#
+# from dependencies in debian/rules (obviously)
+
override_dh_auto_configure:
/usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
PREFIX=/usr \
@@ -19,7 +35,7 @@ override_dh_auto_configure:
QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
CONFIG+=nostrip \
CONFIG+=WITH_I18N \
- QMAKE_CFLAGS_ISYSTEM= \
+ QMAKE_CFLAGS_ISYSTEM=
override_dh_auto_clean:
dh_auto_clean
@@ -27,7 +43,3 @@ override_dh_auto_clean:
override_dh_install:
dh_install --list-missing
- mv $(CURDIR)/debian/lumina-desktop/usr/bin/lumina-desktop \
- $(CURDIR)/debian/lumina-desktop/usr/bin/lumina-desktop.real
- install -m755 $(CURDIR)/debian/lumina-desktop.wrapper \
- $(CURDIR)/debian/lumina-desktop/usr/bin/lumina-desktop
bgstack15