aboutsummaryrefslogtreecommitdiff
path: root/port-files/FreeBSD
diff options
context:
space:
mode:
Diffstat (limited to 'port-files/FreeBSD')
-rw-r--r--port-files/FreeBSD/Makefile37
-rw-r--r--port-files/FreeBSD/distinfo5
-rw-r--r--port-files/FreeBSD/pkg-descr10
-rw-r--r--port-files/FreeBSD/pkg-message7
-rw-r--r--port-files/FreeBSD/pkg-plist1
5 files changed, 37 insertions, 23 deletions
diff --git a/port-files/FreeBSD/Makefile b/port-files/FreeBSD/Makefile
index 033fcb7e..85f5234c 100644
--- a/port-files/FreeBSD/Makefile
+++ b/port-files/FreeBSD/Makefile
@@ -13,42 +13,43 @@ COMMENT= Lumina Desktop Environment
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= xorg>=0:${PORTSDIR}/x11/xorg \
- fluxbox>=0:${PORTSDIR}/x11-wm/fluxbox \
- fluxbox-tenr-styles-pack>=0:${PORTSDIR}/x11-themes/fluxbox-tenr-styles-pack \
- kde4-icons-oxygen>=0:${PORTSDIR}/x11-themes/kde4-icons-oxygen \
- xscreensaver:${PORTSDIR}/x11/xscreensaver \
- xscreensaver-demo:${PORTSDIR}/x11/xscreensaver \
- xbrightness:${PORTSDIR}/x11/xbrightness \
- numlockx:${PORTSDIR}/x11/numlockx
+RUN_DEPENDS= xorg>=0:x11/xorg-minimal \
+ fluxbox>=0:x11-wm/fluxbox \
+ kde4-icons-oxygen>=0:x11-themes/kde4-icons-oxygen \
+ xscreensaver:x11/xscreensaver \
+ xbrightness:x11/xbrightness \
+ xcompmgr:x11-wm/xcompmgr \
+ xrandr:x11/xrandr \
+ numlockx:x11/numlockx
CONFLICTS= lumina-devel-0*
-OPTIONS_DEFINE= MULTIMEDIA PCBSD
+OPTIONS_DEFINE= MULTIMEDIA TRUEOS
OPTIONS_DEFAULT= MULTIMEDIA
MULTIMEDIA_DESC= Install multimedia support backend (gstreamer)
-PCBSD_DESC= Use the PC-BSD system interface settings.
+TRUEOS_DESC= Use the TrueOS system interface settings.
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMULTIMEDIA}
-RUN_DEPENDS+= gstreamer1-plugins-core>=0:${PORTSDIR}/multimedia/gstreamer1-plugins-core
+RUN_DEPENDS+= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
.endif
MAKE_JOBS_UNSAFE=yes
-USE_XORG= x11 xdamage
-USE_XCB= x11extras wm
+USE_XORG= x11 xdamage xcb
+USE_XCB= x11extras wm ewmh util-wm
USE_LDCONFIG= yes
-USE_QT5= core gui network svg multimedia imageformats \
- buildtools x11extras concurrent
+USE_QT5= core gui widgets network svg multimedia imageformats \
+ buildtools_build x11extras concurrent
USES= desktop-file-utils qmake
USE_GITHUB= yes
-GH_ACCOUNT= pcbsd
+GH_ACCOUNT= trueos
#Setup the qmake configuration options
-.if {PORT_OPTIONS:MPCBSD}
-QMAKE_ARGS= CONFIG+="configure PCBSD"
+.if {PORT_OPTIONS:MTRUEOS}
+QMAKE_ARGS= CONFIG+="configure" \
+ DEFAULT_SETTINGS=TrueOS
.endif
.include <bsd.port.mk>
diff --git a/port-files/FreeBSD/distinfo b/port-files/FreeBSD/distinfo
index aaefc4dd..9570700a 100644
--- a/port-files/FreeBSD/distinfo
+++ b/port-files/FreeBSD/distinfo
@@ -1,2 +1,3 @@
-SHA256 (lumina-0.8.4.tar.bz2) = 5fdfbb6b75d86d3cb68dce0453d4675dd7e24312de445e188d5a988512ee9bd3
-SIZE (lumina-0.8.4.tar.bz2) = 23262377
+TIMESTAMP = 1467137694
+SHA256 (trueos-lumina-v0.9.1-Release_GH0.tar.gz) = f62d033b585d46815089a3dce5703c626af23c50db1281a3f1c662fc39cf6006
+SIZE (trueos-lumina-v0.9.1-Release_GH0.tar.gz) = 54665105
diff --git a/port-files/FreeBSD/pkg-descr b/port-files/FreeBSD/pkg-descr
index 0240a632..ce2d052a 100644
--- a/port-files/FreeBSD/pkg-descr
+++ b/port-files/FreeBSD/pkg-descr
@@ -1,3 +1,9 @@
-The Lumina Desktop Environment is a lightweight system interface that is designed for use on any Unix-like operating system. It takes a plugin-based approach, allowing the entire interface to be assembled/arranged by each individual user as desired, with a system-wide default layout which can be customized by the system administrator. This allows every system (or user session) to be designed to maximize the individual user's productivity.
+The Lumina Desktop Environment is a lightweight system interface that is
+designed for use on any Unix-like operating system. It takes a
+plugin-based approach, allowing the entire interface to be assembled or
+arranged by each individual user as desired, with a system-wide default
+layout which can be customized by the system administrator. This allows
+every system (or user session) to be designed to maximize the individual
+user's productivity.
-WWW: https://github.com/pcbsd/lumina
+WWW: http://lumina-desktop.org
diff --git a/port-files/FreeBSD/pkg-message b/port-files/FreeBSD/pkg-message
new file mode 100644
index 00000000..c3742ad9
--- /dev/null
+++ b/port-files/FreeBSD/pkg-message
@@ -0,0 +1,7 @@
+The Lumina Desktop Environment has been installed!
+
+An entry for for launching Lumina from a graphical login manager has already been added to the system, but if you with to start Lumina manually, you will need to do one of the following:
+1) Run "start-lumina-desktop" directly from the command line after logging in.
+2) Put the line "exec start-lumina-desktop" at the end of your user's "~/.xinitrc" file before running startx with any special X11 flags
+
+Also note that the system-wide default settings for Lumina are contained in ${PREFIX}/etc/luminaDesktop.conf[.dist]. While it is possible to customize the desktop to the user's liking after logging in, you may want to adjust the default settings as necessary if there are multiple user accounts on this system.
diff --git a/port-files/FreeBSD/pkg-plist b/port-files/FreeBSD/pkg-plist
index 715e6dc8..fe6ce23e 100644
--- a/port-files/FreeBSD/pkg-plist
+++ b/port-files/FreeBSD/pkg-plist
@@ -33,7 +33,6 @@ share/pixmaps/Lumina-DE.png
share/pixmaps/Insight-FileManager.png
share/xsessions/Lumina-DE.desktop
share/lumina-desktop/desktop-background.jpg
-share/lumina-desktop/defaultapps.conf
share/lumina-desktop/luminaDesktop.conf
share/lumina-desktop/fluxbox-init-rc
share/lumina-desktop/fluxbox-keys
bgstack15