aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/compat1
-rw-r--r--debian/control60
-rw-r--r--debian/copyright36
-rwxr-xr-xdebian/rules38
-rw-r--r--debian/source/format1
6 files changed, 154 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..b0be97fc
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,18 @@
+lumina (1.6.0-1+devuan1) UNRELEASED; urgency=medium
+
+ * Ported to Devuan
+
+ -- Ben Stack <bgstack15@gmail.com> Fri, 09 Oct 2020 10:07:00 -0400
+
+lumina (1.6.0-0.1~mx19+1) mx; urgency=medium
+
+ * New upstream release, port for MX Linux.
+ * Add libxcursor-dev to build-depends.
+
+ -- Steven Pusser <stevep@mxlinux.org> Wed, 27 May 2020 16:57:29 -0700
+
+lumina (1.5.0~sparky6~0-1) unstable; urgency=medium
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- pavroo <pavroo@onet.eu> Mon, 04 Nov 2019 20:39:42 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..f599e28b
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..f3fd7606
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,60 @@
+Source: lumina
+Section: x11
+Priority: optional
+Maintainer: Ben Stack <bgstack15@gmail.com>
+XSBC-Original-Maintainer: Steven Pusser <stevep@mxlinux.org>
+Build-Depends: debhelper (>= 10),
+ libfontconfig1-dev,
+ libfreetype6-dev,
+ libgl1-mesa-dev,
+ libglib2.0-dev,
+ libmtdev-dev,
+ libpoppler-qt5-dev,
+ libpulse-dev,
+ libqt5svg5-dev,
+ libqt5x11extras5-dev,
+ libx11-dev,
+ libx11-xcb-dev,
+ libxcb-composite0-dev,
+ libxcb-damage0-dev,
+ libxcb-ewmh-dev,
+ libxcb-icccm4-dev,
+ libxcb-image0-dev,
+ libxcb-util0-dev,
+ libxcb-xinput-dev | libxcb-xinput0-dev,
+ libxcb1-dev,
+ libxcomposite-dev,
+ libxcursor-dev,
+ libxdamage-dev,
+ libxrender-dev,
+ qtbase5-dev,
+ qtbase5-private-dev,
+ qtdeclarative5-dev,
+ qtmultimedia5-dev,
+ qttools5-dev-tools
+Standards-Version: 3.9.6
+Origin: Devuan
+Homepage: https://github.com/lumina-desktop/lumina
+
+Package: lumina-desktop
+Architecture: any
+Depends: alsa-utils,
+ fluxbox,
+ gstreamer1.0-plugins-base,
+ lxpolkit | lxsession,
+ numlockx,
+ oxygen-icon-theme,
+ pavucontrol,
+ phonon4qt5-backend-gstreamer,
+ procps,
+ qtmultimedia5-examples,
+ sysstat,
+ xbacklight,
+ xscreensaver,
+ ${misc:Depends},
+ ${shlibs:Depends}
+Recommends: acpi,
+ qt5-configuration-tool | qt5ct,
+ usbmount
+Description: lightweight Qt5-based desktop environment
+ Lightweight Qt5-based desktop environment
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..39653980
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,36 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: lumina-desktop
+Source: https://github.com/lumina-desktop/lumina
+
+Files: *
+Copyright: 2012-2020 Ken Moore <moorekou@gmail.com>
+License: BSD-3-Clause
+
+Files: debian/*
+Copyright: 2016-2019 <pavroo@onet.eu>
+License: BSD-3-Clause
+
+License: BSD-3-Clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE HOLDERS OR
+ CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+ EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+ PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..e7bd9e2c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ # disable the systemd integration
+ #sed -i -e 's/shutdown -P -h now/systemctl poweroff/' src-qt5/core/libLumina/LuminaOS-Linux.cpp
+ #sed -i -e 's/shutdown -r now/systemctl reboot/' src-qt5/core/libLumina/LuminaOS-Linux.cpp
+ /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
+ PREFIX=/usr \
+ LIBPREFIX=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_ETCDIR=/etc \
+ QMAKE_CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
+ CONFIG+=nostrip \
+ CONFIG+=WITH_I18N \
+ QMAKE_CFLAGS_ISYSTEM=
+
+override_dh_auto_install:
+ dh_auto_install
+ install -d debian/lumina-desktop/usr/share/icons/hicolor/64x64/apps
+ ( cd debian/lumina-desktop/usr/share/icons/hicolor ; \
+ mv scalable/apps/*.png 64x64/apps ; )
+
+override_dh_auto_clean:
+ dh_auto_clean
+ -find $(CURDIR) -name *.qm -delete
+
+override_dh_strip:
+ dh_strip --no-automatic-dbgsym
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..163aaf8d
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
bgstack15