aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control15
-rwxr-xr-xdebian/rules4
-rw-r--r--lumina-desktop/LPanel.cpp2
-rw-r--r--lumina-desktop/WMProcess.cpp2
-rw-r--r--lumina-desktop/panel-plugins/taskmanager/LTaskButton.cpp6
-rw-r--r--lumina-desktop/panel-plugins/taskmanager/LTaskManagerPlugin.cpp3
6 files changed, 17 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index cae65fe2..36c0ee2f 100644
--- a/debian/control
+++ b/debian/control
@@ -17,11 +17,10 @@ Replaces: lumina-core (<< 0.8.3.372)
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version}),
libluminautils1, lumina-config, lumina-fm, oxygen-icon-theme,
lumina-open, lumina-screenshot, lumina-search, lumina-info,
- lumina-xconfig, lxpolkit, lumina-data, fluxbox,
+ lumina-xconfig, lumina-fileinfo, lxpolkit, lumina-data, fluxbox,
numlockx, xbacklight, xscreensaver, usbmount, alsa-utils, acpi,
gstreamer1.0-plugins-base, phonon4qt5-backend-gstreamer,
pavucontrol
-#lumina-fileinfo
Recommends: qt5-configuration-tool
Description: Lightweight Qt5-based desktop environment
Metapackage depending on all other lumina packages.
@@ -105,12 +104,12 @@ Replaces: lumina-core (<< 0.8.3.372)
Description: Display configuration tool for the lumina desktop environment
Simple multi-head aware display configuration tool for Lumina
-#Package: lumina-fileinfo
-#Architecture: any
-#Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
-#Replaces: lumina-core (<< 0.8.3.372)
-#Description: Desktop file editor for the lumina desktop environment
-# Advanced desktop file (menu) editor for Lumina
+Package: lumina-fileinfo
+Architecture: any
+Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
+Replaces: lumina-core (<< 0.8.3.372)
+Description: Desktop file editor for the lumina desktop environment
+ Advanced desktop file (menu) editor for Lumina
Package: lumina-data
Architecture: all
diff --git a/debian/rules b/debian/rules
index 8ae23bc8..25ef3373 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,8 +24,8 @@ QMAKE_EXTRA_DIRS = libLumina \
lumina-screenshot \
lumina-search \
lumina-info \
- lumina-xconfig #\
-# lumina-fileinfo
+ lumina-xconfig \
+ lumina-fileinfo
%:
dh $@ --parallel
diff --git a/lumina-desktop/LPanel.cpp b/lumina-desktop/LPanel.cpp
index 1f59ba8b..d5be8670 100644
--- a/lumina-desktop/LPanel.cpp
+++ b/lumina-desktop/LPanel.cpp
@@ -12,6 +12,7 @@
LPanel::LPanel(QSettings *file, int scr, int num, QWidget *parent) : QWidget(){
//Take care of inputs
+ this->setMouseTracking(true);
if(DEBUG){ qDebug() << " - Creating Panel:" << scr << num; }
bgWindow = parent; //save for later
//Setup the widget overlay for the entire panel to provide transparency effects
@@ -283,6 +284,7 @@ void LPanel::enterEvent(QEvent *event){
//Move the panel out so it is fully available
this->move(showpoint);
}
+ this->activateWindow();
event->accept(); //just to quiet the compile warning
}
diff --git a/lumina-desktop/WMProcess.cpp b/lumina-desktop/WMProcess.cpp
index 41cfb2bd..e84e4c22 100644
--- a/lumina-desktop/WMProcess.cpp
+++ b/lumina-desktop/WMProcess.cpp
@@ -85,7 +85,7 @@ QString WMProcess::setupWM(){
if(!QFile::exists(QDir::homePath()+"/.fluxbox")){
QDir dir; dir.mkpath(QDir::homePath()+"/.fluxbox");
}
- cmd = "fluxbox -rc "+confDir+"/fluxbox-init";
+ cmd = "fluxbox -rc "+confDir+"/fluxbox-init -no-slit -no-toolbar";
}else {
cmd = WM;
}
diff --git a/lumina-desktop/panel-plugins/taskmanager/LTaskButton.cpp b/lumina-desktop/panel-plugins/taskmanager/LTaskButton.cpp
index 20607c60..eda1f2cd 100644
--- a/lumina-desktop/panel-plugins/taskmanager/LTaskButton.cpp
+++ b/lumina-desktop/panel-plugins/taskmanager/LTaskButton.cpp
@@ -193,9 +193,9 @@ void LTaskButton::minimizeWindow(){
void LTaskButton::triggerWindow(){
LWinInfo win = currentWindow();
//Check which state the window is currently in and flip it to the other
- LXCB::WINDOWSTATE state = cstate;
- if(DEBUG){ qDebug() << "Window State: " << state; }
- if(state == LXCB::ACTIVE){
+ //LXCB::WINDOWSTATE state = cstate;
+ //if(DEBUG){ qDebug() << "Window State: " << state; }
+ if(cstate == LXCB::ACTIVE){
if(DEBUG){ qDebug() << "Minimize Window:" << this->text(); }
LSession::handle()->XCB->MinimizeWindow(win.windowID());
QTimer::singleShot(100, this, SLOT(UpdateButton()) ); //make sure to update this button if losing active status
diff --git a/lumina-desktop/panel-plugins/taskmanager/LTaskManagerPlugin.cpp b/lumina-desktop/panel-plugins/taskmanager/LTaskManagerPlugin.cpp
index 8f73ffa1..9da86da8 100644
--- a/lumina-desktop/panel-plugins/taskmanager/LTaskManagerPlugin.cpp
+++ b/lumina-desktop/panel-plugins/taskmanager/LTaskManagerPlugin.cpp
@@ -35,7 +35,8 @@ void LTaskManagerPlugin::UpdateButtons(){
//Get the current window list
QList<WId> winlist = LSession::handle()->XCB->WindowList();
//Do not change the status of the previously active window if it just changed to a non-visible window
- bool skipActive = false;//!winlist.contains( LSession::handle()->XCB->ActiveWindow() );
+ WId activeWin = LSession::handle()->XCB->ActiveWindow();
+ bool skipActive = !winlist.contains(activeWin);
//qDebug() << "Update Buttons:" << winlist;
if(updating > ctime){ return; } //another thread kicked off already - stop this one
//Now go through all the current buttons first
bgstack15