aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/merge-lumina-i18n.sh22
2 files changed, 16 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 00bb7b30..73f0bacb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ lumina-desktop (0.9.1.1421-1nano) unstable; urgency=low
* update lumina-desktop.install
* add lumina-textedit package
* add lumina-textedit as dependency for lumina-desktop
+ * update debian/merge-lumina-i18n.sh
-- Christopher Roy Bratusek <nano@jpberlin.de> Wed, 25 May 2016 20:59:42 +0200
diff --git a/debian/merge-lumina-i18n.sh b/debian/merge-lumina-i18n.sh
index 7bdded0c..a69bcbfe 100755
--- a/debian/merge-lumina-i18n.sh
+++ b/debian/merge-lumina-i18n.sh
@@ -10,15 +10,22 @@ git clone https://github.com/pcbsd/lumina-i18n.git
LANGS=("${LNGDIR}"/*)
LANGS=(${LANGS[@]/*\/ts\/})
-UTILS=( config desktop fileinfo fm info open screenshot search xconfig )
-
-echo ${LANGS[@]}
+UTILS=( config desktop fileinfo fm info open screenshot search textedit xconfig )
for lng in ${LANGS[@]}; do
for utl in ${UTILS[@]}; do
- [[ -e "${LNGDIR}"/${lng}/lumina-${utl}.ts ]] && \
- cp "${LNGDIR}"/${lng}/lumina-${utl}.ts \
- "${CURDIR}"/lumina-${utl}/i18n/lumina-${utl}_${lng}.ts
+ if [[ -e "${LNGDIR}"/${lng}/lumina-${utl}.ts ]]; then
+ if [[ -d "${CURDIR}"/src-qt5/core/lumina-${utl} ]]; then
+ cp "${LNGDIR}"/${lng}/lumina-${utl}.ts \
+ "${CURDIR}"/src-qt5/core/lumina-${utl}/i18n/lumina-${utl}_${lng}.ts
+ elif [[ -d "${CURDIR}"/src-qt5/core-utils/lumina-${utl} ]]; then
+ cp "${LNGDIR}"/${lng}/lumina-${utl}.ts \
+ "${CURDIR}"/src-qt5/core-utils/lumina-${utl}/i18n/lumina-${utl}_${lng}.ts
+ elif [[ -d "${CURDIR}"/src-qt5/desktop-utils/lumina-${utl} ]]; then
+ cp "${LNGDIR}"/${lng}/lumina-${utl}.ts \
+ "${CURDIR}"/src-qt5/desktop-utils/lumina-${utl}/i18n/lumina-${utl}_${lng}.ts
+ fi
+ fi
done
done
@@ -28,6 +35,7 @@ echo "updated lumina translations."
# first ensure all translations are known to GIT
# then create a commit using only the translation files
# other changes to the source will still be tracked by dpkg-source
-[[ -d "${CURDIR}"/.git ]] && ( git add */i18n/*.ts && git commit */i18n/*.ts \
+[[ -d "${CURDIR}"/.git ]] && ( git add src-qt5/*/*/i18n/*.ts && git commit src-qt5/*/*/i18n/*.ts \
-m "merge latest translations from https://github.com/pcbsd/lumina-i18n.git" )
+
rm -rf lumina-i18n
bgstack15