aboutsummaryrefslogtreecommitdiff
path: root/port-files/lumina-9999.ebuild
diff options
context:
space:
mode:
authorKen Moore <moorekou@gmail.com>2016-06-20 11:51:28 -0400
committerKen Moore <moorekou@gmail.com>2016-06-20 11:51:28 -0400
commiteec8410951b887a2fd70798ab77366b2685dbb63 (patch)
treead2b47fd3837118f62c7931e2245886144d211a3 /port-files/lumina-9999.ebuild
parentOops - forgot to add a couple new .desktop files to the git repo. (diff)
downloadlumina-eec8410951b887a2fd70798ab77366b2685dbb63.tar.gz
lumina-eec8410951b887a2fd70798ab77366b2685dbb63.tar.bz2
lumina-eec8410951b887a2fd70798ab77366b2685dbb63.zip
Large update to all the port-files.
1) Move all the port files (.spec, .ebuild, debian dir, etc..) into the port-files dir. 2) Move all the FreeBSD port files into a "port-files/FreeBSD" sub-dir 3) Update all the build/install scripts (as much as possible - needs review by the porters) to account for the directory heirarchy change 4) Update the .gitignore file a bit so it is also aware of the new directory heirarchy
Diffstat (limited to 'port-files/lumina-9999.ebuild')
-rw-r--r--port-files/lumina-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/port-files/lumina-9999.ebuild b/port-files/lumina-9999.ebuild
new file mode 100644
index 00000000..c8dd7108
--- /dev/null
+++ b/port-files/lumina-9999.ebuild
@@ -0,0 +1,42 @@
+# Lumina-DE source code
+# Copyright (c) 2016, Ken Moore
+# Available under the 3-clause BSD license
+# See the LICENSE file for full details
+
+EAPI=6
+
+inherit git-r3 qmake-utils versionator
+
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="https://github.com/pcbsd/${PN}"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm"
+RDEPEND="${DEPEND}
+ x11-misc/numlockx
+ x11-wm/fluxbox
+ x11-apps/xbacklight
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+src_compile(){
+
+ eqmake5 PREFIX="${ROOT}usr" LIBPREFIX="${ROOT}usr/lib" DESTDIR="${D}" CONFIG+="NO_I18N"
+ emake
+}
bgstack15