aboutsummaryrefslogtreecommitdiff
path: root/port-files/FreeBSD/Makefile
diff options
context:
space:
mode:
authorKen Moore <moorekou@gmail.com>2016-06-29 12:26:59 -0400
committerKen Moore <moorekou@gmail.com>2016-06-29 12:26:59 -0400
commit7ae2868785f32f9bba49df22c9679fdb23edb263 (patch)
tree923863ddfb08896d40157cb8791db57468517428 /port-files/FreeBSD/Makefile
parentAdd Control+[shift]+Tab shortcuts for cycling between open windows in grouped... (diff)
parentAnother couple quick fixes for the FreeBSD port files. (diff)
downloadlumina-7ae2868785f32f9bba49df22c9679fdb23edb263.tar.gz
lumina-7ae2868785f32f9bba49df22c9679fdb23edb263.tar.bz2
lumina-7ae2868785f32f9bba49df22c9679fdb23edb263.zip
Merge branch 'master' of github.com:trueos/lumina
Diffstat (limited to 'port-files/FreeBSD/Makefile')
-rw-r--r--port-files/FreeBSD/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/port-files/FreeBSD/Makefile b/port-files/FreeBSD/Makefile
index 033fcb7e..85f5234c 100644
--- a/port-files/FreeBSD/Makefile
+++ b/port-files/FreeBSD/Makefile
@@ -13,42 +13,43 @@ COMMENT= Lumina Desktop Environment
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= xorg>=0:${PORTSDIR}/x11/xorg \
- fluxbox>=0:${PORTSDIR}/x11-wm/fluxbox \
- fluxbox-tenr-styles-pack>=0:${PORTSDIR}/x11-themes/fluxbox-tenr-styles-pack \
- kde4-icons-oxygen>=0:${PORTSDIR}/x11-themes/kde4-icons-oxygen \
- xscreensaver:${PORTSDIR}/x11/xscreensaver \
- xscreensaver-demo:${PORTSDIR}/x11/xscreensaver \
- xbrightness:${PORTSDIR}/x11/xbrightness \
- numlockx:${PORTSDIR}/x11/numlockx
+RUN_DEPENDS= xorg>=0:x11/xorg-minimal \
+ fluxbox>=0:x11-wm/fluxbox \
+ kde4-icons-oxygen>=0:x11-themes/kde4-icons-oxygen \
+ xscreensaver:x11/xscreensaver \
+ xbrightness:x11/xbrightness \
+ xcompmgr:x11-wm/xcompmgr \
+ xrandr:x11/xrandr \
+ numlockx:x11/numlockx
CONFLICTS= lumina-devel-0*
-OPTIONS_DEFINE= MULTIMEDIA PCBSD
+OPTIONS_DEFINE= MULTIMEDIA TRUEOS
OPTIONS_DEFAULT= MULTIMEDIA
MULTIMEDIA_DESC= Install multimedia support backend (gstreamer)
-PCBSD_DESC= Use the PC-BSD system interface settings.
+TRUEOS_DESC= Use the TrueOS system interface settings.
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMULTIMEDIA}
-RUN_DEPENDS+= gstreamer1-plugins-core>=0:${PORTSDIR}/multimedia/gstreamer1-plugins-core
+RUN_DEPENDS+= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
.endif
MAKE_JOBS_UNSAFE=yes
-USE_XORG= x11 xdamage
-USE_XCB= x11extras wm
+USE_XORG= x11 xdamage xcb
+USE_XCB= x11extras wm ewmh util-wm
USE_LDCONFIG= yes
-USE_QT5= core gui network svg multimedia imageformats \
- buildtools x11extras concurrent
+USE_QT5= core gui widgets network svg multimedia imageformats \
+ buildtools_build x11extras concurrent
USES= desktop-file-utils qmake
USE_GITHUB= yes
-GH_ACCOUNT= pcbsd
+GH_ACCOUNT= trueos
#Setup the qmake configuration options
-.if {PORT_OPTIONS:MPCBSD}
-QMAKE_ARGS= CONFIG+="configure PCBSD"
+.if {PORT_OPTIONS:MTRUEOS}
+QMAKE_ARGS= CONFIG+="configure" \
+ DEFAULT_SETTINGS=TrueOS
.endif
.include <bsd.port.mk>
bgstack15