aboutsummaryrefslogtreecommitdiff
path: root/port-files-master
diff options
context:
space:
mode:
authorKen Moore <ken@pcbsd.org>2016-08-08 08:48:42 -0400
committerKen Moore <ken@pcbsd.org>2016-08-08 08:48:42 -0400
commit4714fcf3ed34980e5e206ebf247b0e6871d63146 (patch)
tree951873babcf45cb5c86ce5fcdd371767f852ef8f /port-files-master
parentAdd a simple check to the panel update routine to verify that the "_NET_WM_ST... (diff)
parentAdd the missing Makefile, and fix missing USE_GL in meantime (diff)
downloadlumina-4714fcf3ed34980e5e206ebf247b0e6871d63146.tar.gz
lumina-4714fcf3ed34980e5e206ebf247b0e6871d63146.tar.bz2
lumina-4714fcf3ed34980e5e206ebf247b0e6871d63146.zip
Merge branch 'master' of github.com:trueos/lumina
Diffstat (limited to 'port-files-master')
-rw-r--r--port-files-master/Makefile53
-rw-r--r--port-files-master/pkg-descr9
-rw-r--r--port-files-master/pkg-install36
-rw-r--r--port-files-master/pkg-message7
-rw-r--r--port-files-master/pkg-plist64
5 files changed, 169 insertions, 0 deletions
diff --git a/port-files-master/Makefile b/port-files-master/Makefile
new file mode 100644
index 00000000..58adc55e
--- /dev/null
+++ b/port-files-master/Makefile
@@ -0,0 +1,53 @@
+# Created by: Ken Moore <ken@pcbsd.org>
+# $FreeBSD$
+
+PORTNAME= lumina
+PORTVERSION= %%CHGVERSION%%
+PORTEPOCH= 1
+CATEGORIES= x11
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Lumina Desktop Environment
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= fluxbox>=0:x11-wm/fluxbox \
+ kde4-icons-oxygen>=0:x11-themes/kde4-icons-oxygen \
+ xscreensaver:x11/xscreensaver \
+ xbrightness:x11/xbrightness \
+ compton:x11-wm/compton \
+ xrandr:x11/xrandr \
+ numlockx:x11/numlockx
+
+CONFLICTS= lumina-devel-0*
+
+OPTIONS_DEFINE= MULTIMEDIA TRUEOS
+OPTIONS_DEFAULT= MULTIMEDIA
+MULTIMEDIA_DESC= Install multimedia support backend (gstreamer)
+TRUEOS_DESC= Use the TrueOS system interface settings.
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMULTIMEDIA}
+RUN_DEPENDS+= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
+.endif
+
+MAKE_JOBS_UNSAFE=yes
+
+USE_GL= gl
+USE_XORG= x11 xdamage xcb
+USE_XCB= x11extras wm ewmh util-wm
+USE_LDCONFIG= yes
+USE_QT5= core gui widgets network svg multimedia imageformats \
+ buildtools_build x11extras concurrent
+USES= desktop-file-utils qmake
+USE_GITHUB= yes
+GH_ACCOUNT= trueos
+GH_TAGNAME= %%GHTAG%%
+
+#Setup the qmake configuration options
+.if ${PORT_OPTIONS:MTRUEOS}
+QMAKE_ARGS= DEFAULT_SETTINGS=TrueOS
+.endif
+
+.include <bsd.port.mk>
diff --git a/port-files-master/pkg-descr b/port-files-master/pkg-descr
new file mode 100644
index 00000000..ce2d052a
--- /dev/null
+++ b/port-files-master/pkg-descr
@@ -0,0 +1,9 @@
+The Lumina Desktop Environment is a lightweight system interface that is
+designed for use on any Unix-like operating system. It takes a
+plugin-based approach, allowing the entire interface to be assembled or
+arranged by each individual user as desired, with a system-wide default
+layout which can be customized by the system administrator. This allows
+every system (or user session) to be designed to maximize the individual
+user's productivity.
+
+WWW: http://lumina-desktop.org
diff --git a/port-files-master/pkg-install b/port-files-master/pkg-install
new file mode 100644
index 00000000..c406d96e
--- /dev/null
+++ b/port-files-master/pkg-install
@@ -0,0 +1,36 @@
+#!/bin/sh
+# Script to install preload.conf
+
+PREFIX=${PKG_PREFIX-/usr/local}
+
+if [ "$2" != "POST-INSTALL" ] ; then
+ exit 0
+fi
+
+# If this is during staging, we can skip for now
+echo $PREFIX | grep -q '/stage/'
+if [ $? -eq 0 ] ; then
+ exit 0
+fi
+
+# Copy over the rc.conf.trueos file
+install -m 644 ${PREFIX}/share/trueos/conf/rc.conf.trueos /etc/rc.conf.trueos
+if [ -e "/etc/default/trueos" -o -e "/etc/defaults/trueos-desktop" ] ; then
+ install -m 644 ${PREFIX}/share/trueos/conf/loader.conf.trueos /boot/loader.conf.trueos
+ install -m 644 ${PREFIX}/share/trueos/conf/brand-trueos.4th /boot/brand-trueos.4th
+else
+ install -m 644 ${PREFIX}/share/trueos/conf/loader.conf.trueos /boot/loader.conf.trueos
+ install -m 644 ${PREFIX}/share/trueos/conf/brand-trueos.4th /boot/brand-trueos.4th
+fi
+
+if [ ! -e "${PREFIX}/etc/trueos.conf" ] ; then
+ # Do the first-time setup
+ echo "Doing first-time bootstrap"
+ if [ -e "/etc/defaults/trueos-desktop" ] ; then
+ tar cvf - -C ${PREFIX}/share/trueos/desktop-defaults/ . 2>/dev/null | tar xvpf - -C / 2>/dev/null
+ else
+ tar cvf - -C ${PREFIX}/share/trueos/server-defaults/ . 2>/dev/null | tar xvpf - -C / 2>/dev/null
+ fi
+fi
+
+exit 0
diff --git a/port-files-master/pkg-message b/port-files-master/pkg-message
new file mode 100644
index 00000000..c3742ad9
--- /dev/null
+++ b/port-files-master/pkg-message
@@ -0,0 +1,7 @@
+The Lumina Desktop Environment has been installed!
+
+An entry for for launching Lumina from a graphical login manager has already been added to the system, but if you with to start Lumina manually, you will need to do one of the following:
+1) Run "start-lumina-desktop" directly from the command line after logging in.
+2) Put the line "exec start-lumina-desktop" at the end of your user's "~/.xinitrc" file before running startx with any special X11 flags
+
+Also note that the system-wide default settings for Lumina are contained in ${PREFIX}/etc/luminaDesktop.conf[.dist]. While it is possible to customize the desktop to the user's liking after logging in, you may want to adjust the default settings as necessary if there are multiple user accounts on this system.
diff --git a/port-files-master/pkg-plist b/port-files-master/pkg-plist
new file mode 100644
index 00000000..b260ae6a
--- /dev/null
+++ b/port-files-master/pkg-plist
@@ -0,0 +1,64 @@
+bin/start-lumina-desktop
+bin/lumina-desktop
+bin/lumina-open
+bin/lumina-config
+bin/lumina-fm
+bin/lumina-screenshot
+bin/lumina-search
+bin/lumina-info
+bin/lumina-xconfig
+bin/lumina-fileinfo
+bin/lumina-textedit
+bin/lte
+etc/luminaDesktop.conf.dist
+lib/libLuminaUtils.so
+lib/libLuminaUtils.so.1
+lib/libLuminaUtils.so.1.0
+lib/libLuminaUtils.so.1.0.0
+include/LuminaXDG.h
+include/LuminaUtils.h
+include/LuminaX11.h
+include/LuminaThemes.h
+include/LuminaOS.h
+include/LuminaSingleApplication.h
+share/applications/lumina-config.desktop
+share/applications/lumina-fileinfo.desktop
+share/applications/lumina-fm.desktop
+share/applications/lumina-info.desktop
+share/applications/lumina-screenshot.desktop
+share/applications/lumina-search.desktop
+share/applications/lumina-support.desktop
+share/applications/lumina-textedit.desktop
+share/applications/lumina-xconfig.desktop
+share/pixmaps/Lumina-DE.png
+share/pixmaps/Insight-FileManager.png
+share/xsessions/Lumina-DE.desktop
+share/lumina-desktop/desktop-background.jpg
+share/lumina-desktop/luminaDesktop.conf
+share/lumina-desktop/fluxbox-init-rc
+share/lumina-desktop/fluxbox-keys
+share/lumina-desktop/Login.ogg
+share/lumina-desktop/Logout.ogg
+share/lumina-desktop/colors/Black.qss.colors
+share/lumina-desktop/colors/Blue-Light.qss.colors
+share/lumina-desktop/colors/Grey-Dark.qss.colors
+share/lumina-desktop/colors/Lumina-Red.qss.colors
+share/lumina-desktop/colors/Lumina-Green.qss.colors
+share/lumina-desktop/colors/Lumina-Purple.qss.colors
+share/lumina-desktop/colors/Lumina-Gold.qss.colors
+share/lumina-desktop/colors/Lumina-Glass.qss.colors
+share/lumina-desktop/colors/PCBSD10-Default.qss.colors
+share/lumina-desktop/colors/Solarized-Dark.qss.colors
+share/lumina-desktop/colors/Solarized-Light.qss.colors
+share/lumina-desktop/themes/Glass.qss.template
+share/lumina-desktop/themes/Lumina-default.qss.template
+share/lumina-desktop/themes/None.qss.template
+share/lumina-desktop/menu-scripts/ls.json.sh
+share/wallpapers/Lumina-DE/Lumina_Wispy_gold.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_green.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_purple.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_blue-grey-zoom.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_blue-grey.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_grey-blue-zoom.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_grey-blue.jpg
+share/wallpapers/Lumina-DE/Lumina_Wispy_red.jpg
bgstack15