aboutsummaryrefslogtreecommitdiff
path: root/lumina-desktop/panel-plugins/userbutton
diff options
context:
space:
mode:
authorKen Moore <ken@pcbsd.org>2015-01-28 12:35:48 -0500
committerKen Moore <ken@pcbsd.org>2015-01-28 12:35:48 -0500
commit09ffe0e5e565f3fd8a8d98502508bebb94e1a63e (patch)
treef34dd309525642f1366503175445bc51a9142092 /lumina-desktop/panel-plugins/userbutton
parentAlso add the lumina-info utility to the i18n-projects file (so it gets added ... (diff)
downloadlumina-09ffe0e5e565f3fd8a8d98502508bebb94e1a63e.tar.gz
lumina-09ffe0e5e565f3fd8a8d98502508bebb94e1a63e.tar.bz2
lumina-09ffe0e5e565f3fd8a8d98502508bebb94e1a63e.zip
Add knowledge of the lumina-info utility to the Lumina desktop (userbutton, config menu). Also make sure that there is a *.desktop shortcut for the application (and update the pkg-plist)
Also allow for "-<something>" to be put in the version number without messing up the version checking routine, and tag the current version on the master branch as 0.8.2-devel (once the stable/official release is branched, the "-devel" tag will get either dropped or changed to "-release" in that branch, with the master branch moving on to the next <version>-devel)
Diffstat (limited to 'lumina-desktop/panel-plugins/userbutton')
-rw-r--r--lumina-desktop/panel-plugins/userbutton/UserWidget.cpp3
-rw-r--r--lumina-desktop/panel-plugins/userbutton/UserWidget.h5
-rw-r--r--lumina-desktop/panel-plugins/userbutton/UserWidget.ui70
3 files changed, 66 insertions, 12 deletions
diff --git a/lumina-desktop/panel-plugins/userbutton/UserWidget.cpp b/lumina-desktop/panel-plugins/userbutton/UserWidget.cpp
index 5f50e707..d5f8cd2e 100644
--- a/lumina-desktop/panel-plugins/userbutton/UserWidget.cpp
+++ b/lumina-desktop/panel-plugins/userbutton/UserWidget.cpp
@@ -34,7 +34,7 @@ UserWidget::UserWidget(QWidget* parent) : QTabWidget(parent), ui(new Ui::UserWid
ui->tool_config_screensaver->setIcon( LXDG::findIcon("preferences-desktop-screensaver","") );
ui->tool_home_gohome->setIcon( LXDG::findIcon("go-home","") );
ui->tool_home_browse->setIcon( LXDG::findIcon("document-open","") );
-
+ ui->tool_config_about->setIcon( LXDG::findIcon("lumina","") );
//Connect the signals/slots
connect(ui->tool_desktopsettings, SIGNAL(clicked()), this, SLOT(openDeskSettings()) );
connect(ui->tool_config_screensaver, SIGNAL(clicked()), this, SLOT(openScreenSaverConfig()) );
@@ -44,6 +44,7 @@ UserWidget::UserWidget(QWidget* parent) : QTabWidget(parent), ui(new Ui::UserWid
connect(ui->combo_app_cats, SIGNAL(currentIndexChanged(int)), this, SLOT(updateApps()) );
connect(ui->tool_home_gohome, SIGNAL(clicked()), this, SLOT(slotGoHome()) );
connect(ui->tool_home_browse, SIGNAL(clicked()), this, SLOT(slotOpenDir()) );
+ connect(ui->tool_config_about, SIGNAL(clicked()), this, SLOT(openLuminaInfo()) );
//Setup the special buttons
QString APPSTORE = LOS::AppStoreShortcut();
diff --git a/lumina-desktop/panel-plugins/userbutton/UserWidget.h b/lumina-desktop/panel-plugins/userbutton/UserWidget.h
index 06ad22e8..108f540f 100644
--- a/lumina-desktop/panel-plugins/userbutton/UserWidget.h
+++ b/lumina-desktop/panel-plugins/userbutton/UserWidget.h
@@ -80,7 +80,10 @@ private slots:
void openScreenSaverConfig(){
LaunchItem(SSAVER, false);
}
-
+ void openLuminaInfo(){
+ LaunchItem("lumina-info",false);
+ }
+
protected:
void mouseMoveEvent( QMouseEvent *event);
diff --git a/lumina-desktop/panel-plugins/userbutton/UserWidget.ui b/lumina-desktop/panel-plugins/userbutton/UserWidget.ui
index 764feddf..9a307cb6 100644
--- a/lumina-desktop/panel-plugins/userbutton/UserWidget.ui
+++ b/lumina-desktop/panel-plugins/userbutton/UserWidget.ui
@@ -17,7 +17,7 @@
<enum>QTabWidget::West</enum>
</property>
<property name="currentIndex">
- <number>2</number>
+ <number>3</number>
</property>
<widget class="QWidget" name="tab_fav">
<attribute name="title">
@@ -30,7 +30,16 @@
<property name="spacing">
<number>2</number>
</property>
- <property name="margin">
+ <property name="leftMargin">
+ <number>1</number>
+ </property>
+ <property name="topMargin">
+ <number>1</number>
+ </property>
+ <property name="rightMargin">
+ <number>1</number>
+ </property>
+ <property name="bottomMargin">
<number>1</number>
</property>
<item>
@@ -161,8 +170,8 @@
<rect>
<x>0</x>
<y>0</y>
- <width>262</width>
- <height>245</height>
+ <width>98</width>
+ <height>28</height>
</rect>
</property>
</widget>
@@ -181,7 +190,16 @@
<property name="spacing">
<number>2</number>
</property>
- <property name="margin">
+ <property name="leftMargin">
+ <number>1</number>
+ </property>
+ <property name="topMargin">
+ <number>1</number>
+ </property>
+ <property name="rightMargin">
+ <number>1</number>
+ </property>
+ <property name="bottomMargin">
<number>1</number>
</property>
<item>
@@ -258,8 +276,8 @@
<rect>
<x>0</x>
<y>0</y>
- <width>262</width>
- <height>245</height>
+ <width>98</width>
+ <height>28</height>
</rect>
</property>
</widget>
@@ -278,7 +296,16 @@
<property name="spacing">
<number>2</number>
</property>
- <property name="margin">
+ <property name="leftMargin">
+ <number>1</number>
+ </property>
+ <property name="topMargin">
+ <number>1</number>
+ </property>
+ <property name="rightMargin">
+ <number>1</number>
+ </property>
+ <property name="bottomMargin">
<number>1</number>
</property>
<item>
@@ -392,8 +419,8 @@
<rect>
<x>0</x>
<y>0</y>
- <width>262</width>
- <height>245</height>
+ <width>98</width>
+ <height>28</height>
</rect>
</property>
</widget>
@@ -510,6 +537,29 @@
</property>
</spacer>
</item>
+ <item>
+ <widget class="Line" name="line">
+ <property name="orientation">
+ <enum>Qt::Horizontal</enum>
+ </property>
+ </widget>
+ </item>
+ <item>
+ <widget class="QToolButton" name="tool_config_about">
+ <property name="sizePolicy">
+ <sizepolicy hsizetype="Preferred" vsizetype="Fixed">
+ <horstretch>0</horstretch>
+ <verstretch>0</verstretch>
+ </sizepolicy>
+ </property>
+ <property name="text">
+ <string>About the Lumina Desktop</string>
+ </property>
+ <property name="toolButtonStyle">
+ <enum>Qt::ToolButtonTextBesideIcon</enum>
+ </property>
+ </widget>
+ </item>
</layout>
</widget>
</widget>
bgstack15