aboutsummaryrefslogtreecommitdiff
path: root/lumina-0.9_pre.ebuild
diff options
context:
space:
mode:
authorKen Moore <moorekou@gmail.com>2016-03-23 13:31:21 -0400
committerKen Moore <moorekou@gmail.com>2016-03-23 13:31:21 -0400
commit081572c5eb2ee212493a30e0dfb0b5c46b6cf775 (patch)
tree41b1d98ca762c4946e9550f4900db624f2226008 /lumina-0.9_pre.ebuild
parentFix up the format of the new wallpapers (use jpg instead on png: ~3MB per ima... (diff)
parentBut still, it's nice to have a Categories in there because #183 (diff)
downloadlumina-081572c5eb2ee212493a30e0dfb0b5c46b6cf775.tar.gz
lumina-081572c5eb2ee212493a30e0dfb0b5c46b6cf775.tar.bz2
lumina-081572c5eb2ee212493a30e0dfb0b5c46b6cf775.zip
Merge pull request #207 from rubin55/master
Gentoo support, NVMe disks as HDRIVE, Desktop specification fixes
Diffstat (limited to 'lumina-0.9_pre.ebuild')
-rw-r--r--lumina-0.9_pre.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/lumina-0.9_pre.ebuild b/lumina-0.9_pre.ebuild
new file mode 100644
index 00000000..8d232b23
--- /dev/null
+++ b/lumina-0.9_pre.ebuild
@@ -0,0 +1,50 @@
+# Lumina-DE source code
+# Copyright (c) 2016, Ken Moore
+# Available under the 3-clause BSD license
+# See the LICENSE file for full details
+
+EAPI=5
+
+inherit git-r3 qmake-utils versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="https://github.com/pcbsd/${PN}"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+#EGIT_COMMIT="v${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="dev-qt/linguist-tools
+ dev-qt/qtconcurrent
+ dev-qt/qtcore
+ dev-qt/qtmultimedia
+ dev-qt/qtnetwork
+ dev-qt/qtwidgets
+ dev-qt/qtx11extras
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm"
+RDEPEND="${DEPEND}
+ x11-misc/numlockx
+ x11-terms/xterm
+ x11-wm/fluxbox
+ x11-apps/xbacklight
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+src_compile(){
+
+ eqmake5 PREFIX="${ROOT}usr" LIBPREFIX="${ROOT}usr/lib" DESTDIR="${D}" CONFIG+="NO_I18N" || die "eqmake5 failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake install || die "emake install failed"
+}
bgstack15