aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Moore <ken@ixsystems.com>2017-05-18 15:47:16 -0400
committerKen Moore <ken@ixsystems.com>2017-05-18 15:47:16 -0400
commit2aeff150b40e03f55bf2c5c31ccc09e3c0cbfe76 (patch)
treed92a8cc3840fbef113b70c3d4dd0f8c84827f544
parentAdd the ability to scan/migrate desktop/panel settings from one monitor ID to... (diff)
parentrename readme so github knows its a markdown file (diff)
downloadlumina-2aeff150b40e03f55bf2c5c31ccc09e3c0cbfe76.tar.gz
lumina-2aeff150b40e03f55bf2c5c31ccc09e3c0cbfe76.tar.bz2
lumina-2aeff150b40e03f55bf2c5c31ccc09e3c0cbfe76.zip
Merge branch 'master' of github.com:trueos/lumina
-rw-r--r--port-files/FreeBSD/deskutils/lumina-notify/pkg-descr2
-rw-r--r--port-files/FreeBSD/deskutils/lumina-notify/pkg-plist1
-rw-r--r--src-qt5/desktop-utils/lumina-notify/README.md33
-rw-r--r--src-qt5/desktop-utils/lumina-notify/lumina-notify.desktop9
-rw-r--r--src-qt5/desktop-utils/lumina-notify/lumina-notify.pro3
5 files changed, 34 insertions, 14 deletions
diff --git a/port-files/FreeBSD/deskutils/lumina-notify/pkg-descr b/port-files/FreeBSD/deskutils/lumina-notify/pkg-descr
index 9849d9e4..140fc367 100644
--- a/port-files/FreeBSD/deskutils/lumina-notify/pkg-descr
+++ b/port-files/FreeBSD/deskutils/lumina-notify/pkg-descr
@@ -1,3 +1,3 @@
-Alarm/notification utility from the Lumina Desktop
+Notification utility from the Lumina Desktop
WWW: http://lumina-desktop.org
diff --git a/port-files/FreeBSD/deskutils/lumina-notify/pkg-plist b/port-files/FreeBSD/deskutils/lumina-notify/pkg-plist
index a107fa94..9dc4ace5 100644
--- a/port-files/FreeBSD/deskutils/lumina-notify/pkg-plist
+++ b/port-files/FreeBSD/deskutils/lumina-notify/pkg-plist
@@ -1,2 +1 @@
bin/lumina-notify
-share/applications/lumina-notify.desktop
diff --git a/src-qt5/desktop-utils/lumina-notify/README.md b/src-qt5/desktop-utils/lumina-notify/README.md
new file mode 100644
index 00000000..ea71b0f4
--- /dev/null
+++ b/src-qt5/desktop-utils/lumina-notify/README.md
@@ -0,0 +1,33 @@
+### lumina-notify
+
+This is a simple application for launching QDialogs from shell.
+
+Use:
+
+lumina-notify arg1 arg2 arg3 arg4
+
+* arg1 = Message Text
+* arg2 = Button Text (Accept Role)
+* arg3 = Button Text (Reject Role)
+* arg4 = Window Title
+
+For multiple word arguments encapsulate them with "s
+
+***
+Example usage in shell script
+***
+
+~~~~
+#!/bin/csh
+set a=`./lumina-notify "Did Jar Jar do anything wrong?" Yes No "Question"`
+if ($a == 1) then
+set b=`./lumina-notify "Are you sure?" Yes No "Are you Sure?"`
+if ($b == 1) then
+./lumina-notify "Please stop being a hater." Ok Ok "Haters gunna hate"
+else
+set c=`./lumina-notify "Thank you for changing your mind" OK OK "You're Awesome"`
+endif
+else
+./lumina-notify "High Five for Darth Jar Jar" Sure OK "Respect"
+endif`
+~~~~
diff --git a/src-qt5/desktop-utils/lumina-notify/lumina-notify.desktop b/src-qt5/desktop-utils/lumina-notify/lumina-notify.desktop
deleted file mode 100644
index 3aad94f0..00000000
--- a/src-qt5/desktop-utils/lumina-notify/lumina-notify.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Exec=lumina-notify
-Icon=clock
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Utility;
-Name=Lumina Notify
-Comment=Alarm clock and notification system
diff --git a/src-qt5/desktop-utils/lumina-notify/lumina-notify.pro b/src-qt5/desktop-utils/lumina-notify/lumina-notify.pro
index 56684eef..7aa09583 100644
--- a/src-qt5/desktop-utils/lumina-notify/lumina-notify.pro
+++ b/src-qt5/desktop-utils/lumina-notify/lumina-notify.pro
@@ -12,9 +12,6 @@ TARGET = lumina-notify
target.path = $${L_BINDIR}
TEMPLATE = app
-desktop.files=lumina-notify.desktop
-desktop.path=$${L_SHAREDIR}/applications/
-
DEFINES += QT_DEPRECATED_WARNINGS
SOURCES += main.cpp
bgstack15