aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Moore <ken@pcbsd.org>2014-10-29 16:21:34 -0400
committerKen Moore <ken@pcbsd.org>2014-10-29 16:21:34 -0400
commit152b3c2e3f0b554fc79561dfbad83adbba91065c (patch)
tree8f3b0dffdbe17492dde5cd69a03295cce0fca869
parentInsert a sanity check into lumina-config: (diff)
downloadlumina-152b3c2e3f0b554fc79561dfbad83adbba91065c.tar.gz
lumina-152b3c2e3f0b554fc79561dfbad83adbba91065c.tar.bz2
lumina-152b3c2e3f0b554fc79561dfbad83adbba91065c.zip
Tag Lumina version 0.7.1:
This version mainly contains bugfixes and stability fixes from 0.7.0. The only new features are the "window list" menu plugin, and the option to have panels auto-hide.
-rw-r--r--lumina-desktop/LDesktop.cpp5
-rw-r--r--lumina-desktop/LSession.cpp2
-rw-r--r--port-files/Makefile2
3 files changed, 6 insertions, 3 deletions
diff --git a/lumina-desktop/LDesktop.cpp b/lumina-desktop/LDesktop.cpp
index 5e1fb3bf..7988d6b8 100644
--- a/lumina-desktop/LDesktop.cpp
+++ b/lumina-desktop/LDesktop.cpp
@@ -383,7 +383,9 @@ void LDesktop::UpdatePanels(){
if(!found){
qDebug() << " -- Create panel "<< i;
//New panel
- PANELS << new LPanel(settings, desktopnumber, i, bgWindow);
+ LPanel *pan = new LPanel(settings, desktopnumber, i, bgWindow);
+ PANELS << pan;
+ pan->show();
}
}
//Give it a 1/2 second before ensuring that the visible desktop area is correct
@@ -451,6 +453,7 @@ void LDesktop::UpdateBackground(){
//Now update the panel backgrounds
for(int i=0; i<PANELS.length(); i++){
PANELS[i]->update();
+ PANELS[i]->show();
}
bgupdating=false;
}
diff --git a/lumina-desktop/LSession.cpp b/lumina-desktop/LSession.cpp
index 00728d23..9680e749 100644
--- a/lumina-desktop/LSession.cpp
+++ b/lumina-desktop/LSession.cpp
@@ -30,7 +30,7 @@ static QSettings *sessionsettings;
LSession::LSession(int &argc, char ** argv) : QApplication(argc, argv){
this->setApplicationName("Lumina Desktop Environment");
- this->setApplicationVersion("0.7.0");
+ this->setApplicationVersion("0.7.1");
this->setOrganizationName("LuminaDesktopEnvironment");
this->setQuitOnLastWindowClosed(false); //since the LDesktop's are not necessarily "window"s
//Enabled a few of the simple effects by default
diff --git a/port-files/Makefile b/port-files/Makefile
index 0bd2d2bc..d448bd3e 100644
--- a/port-files/Makefile
+++ b/port-files/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lumina
GITVERSION= CHGVERSION
-PORTVERSION= 0.7.0.${GITVERSION}
+PORTVERSION= 0.7.1.${GITVERSION}
PORTEPOCH= 1
CATEGORIES= x11
DISTNAME= ${PORTNAME}-${GITVERSION}
bgstack15