aboutsummaryrefslogtreecommitdiff
path: root/arch/01_build.sh
diff options
context:
space:
mode:
Diffstat (limited to 'arch/01_build.sh')
-rwxr-xr-xarch/01_build.sh8
1 files changed, 5 insertions, 3 deletions
diff --git a/arch/01_build.sh b/arch/01_build.sh
index 1faceaa..3ddab39 100755
--- a/arch/01_build.sh
+++ b/arch/01_build.sh
@@ -1,5 +1,6 @@
#!/bin/bash
+PKGBUILD_NAME=${PKGBUILD_NAME:-'PKGBUILD'}
pacman --noconfirm -Syu --needed base-devel
# this is a very ugly fix for recent makepkg-5.1-chmod-shenanigans, which mess up the build process in docker
sed -E -i 's/^chmod a-s \"\$BUILDDIR\"$/# chmod a-s \"\$BUILDDIR\"/' `which makepkg`
@@ -9,7 +10,8 @@ usermod -d /home/nobody nobody
# we need to un-expire the account, otherwise PAM will complain
usermod -e '' nobody
chown -R nobody .
-# temporary workaround for rust / packed_simd build issue:
-pacman --noconfirm -U https://archive.archlinux.org/packages/r/rust/rust-1%3A1.47.0-4-x86_64.pkg.tar.zst
+if [[ ! -z "${GLOBAL_MENUBAR}" ]];then
+ PKGBUILD_NAME='PKGBUILD_global_menubar'
+fi
# makepkg will not run as root
-sudo -u nobody -E -H makepkg --noconfirm --nosign --syncdeps --cleanbuild
+sudo -u nobody -E -H makepkg --noconfirm --nosign --syncdeps --cleanbuild -p "${PKGBUILD_NAME}"
bgstack15