aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorohfp <1813007-ohfp@users.noreply.gitlab.com>2020-09-30 14:04:18 +0200
committerohfp <1813007-ohfp@users.noreply.gitlab.com>2020-09-30 14:52:19 +0200
commit42d221db4971342edd7ebe75152be53741bb0a7b (patch)
treefb23761477f3f759ba7327845e271227a7a629e3 /PKGBUILD
parentv80.0.1-1 (diff)
downloadlibrewolf-linux-42d221db4971342edd7ebe75152be53741bb0a7b.tar.gz
librewolf-linux-42d221db4971342edd7ebe75152be53741bb0a7b.tar.bz2
librewolf-linux-42d221db4971342edd7ebe75152be53741bb0a7b.zip
v81.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7a21d2..5681828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=librewolf
_pkgname=LibreWolf
# how to get ci vars instead?
-pkgver=80.0.1
-pkgrel=1
+pkgver=81.0
+pkgrel=2
pkgdesc="Community-maintained fork of Firefox, focused on privacy, security and freedom."
arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
@@ -15,21 +15,26 @@ url="https://librewolf-community.gitlab.io/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
- python-setuptools python-psutil git binutils lld)
+ python-setuptools python-psutil python-zstandard git binutils lld)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
+_arch_svn=https://git.archlinux.org/svntogit/packages.git/plain/trunk
source_x86_64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
+ "0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch::${_arch_svn}/0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch?h=packages/firefox"
+ "0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch::${_arch_svn}/0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch?h=packages/firefox"
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
"git+https://gitlab.com/${pkgname}-community/settings.git"
"megabar.patch"
"remove_addons.patch")
source_aarch64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
+ "0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch::${_arch_svn}/0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch?h=packages/firefox"
+ "0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch::${_arch_svn}/0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch?h=packages/firefox"
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
"git+https://gitlab.com/${pkgname}-community/settings.git"
"megabar.patch"
@@ -37,18 +42,22 @@ source_aarch64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/
arm.patch
https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/firefox/build-arm-libopus.patch)
-sha256sums_x86_64=('596b085e32a2d683ba960e161ea65c6271f90f576d4bf956e0d48e83af992c21'
+sha256sums_x86_64=('9328745012178aee5a4f47c833539f7872cc6e0f20a853568a313e60cabd1ec8'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
+ 'c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29'
+ '52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc'
'SKIP'
'SKIP'
- '2bef819c55935f6c72a7aa28273ecddfce0888429a32465feb6c34a16ff1ed9c'
- 'd191e65a0ce3eeba0a3171c143fc93e3ded6c29eb751b90d58a7d3bf1983aca6')
-sha256sums_aarch64=('596b085e32a2d683ba960e161ea65c6271f90f576d4bf956e0d48e83af992c21'
+ '682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
+ '41719289b309912c4b6bc86b41594f671427979481a90c32a9d3d0bf1cdd6d44')
+sha256sums_aarch64=('9328745012178aee5a4f47c833539f7872cc6e0f20a853568a313e60cabd1ec8'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
+ 'c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29'
+ '52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc'
'SKIP'
'SKIP'
- '2bef819c55935f6c72a7aa28273ecddfce0888429a32465feb6c34a16ff1ed9c'
- 'd191e65a0ce3eeba0a3171c143fc93e3ded6c29eb751b90d58a7d3bf1983aca6'
+ '682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
+ '41719289b309912c4b6bc86b41594f671427979481a90c32a9d3d0bf1cdd6d44'
'6ca87d2ac7dc48e6f595ca49ac8151936afced30d268a831c6a064b52037f6b7'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9')
@@ -56,6 +65,11 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
+ # https://bugs.archlinux.org/task/67978
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1660901
+ patch -Np1 -i ../0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
+ patch -Np1 -i ../0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
+
cat >../mozconfig <<END
ac_add_options --enable-application=browser
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
@@ -160,6 +174,7 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MACH_USE_SYSTEM_PYTHON=1
# LTO needs more open files
ulimit -n 4096
bgstack15