aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorohfp <1813007-ohfp@users.noreply.gitlab.com>2021-01-07 21:40:39 +0100
committerohfp <1813007-ohfp@users.noreply.gitlab.com>2021-01-07 21:40:39 +0100
commit4020a6ed0e31ff7b4f9319edec3939fca754a2d1 (patch)
tree1c7cb3edbbf1dc05016430d7252de801ba9134ce /PKGBUILD
parentBlock some more undesired requests (diff)
downloadlibrewolf-linux-4020a6ed0e31ff7b4f9319edec3939fca754a2d1.tar.gz
librewolf-linux-4020a6ed0e31ff7b4f9319edec3939fca754a2d1.tar.bz2
librewolf-linux-4020a6ed0e31ff7b4f9319edec3939fca754a2d1.zip
updated changelog; added unity-menubar.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d66b6e7..2038e17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=librewolf
_pkgname=LibreWolf
# how to get ci vars instead?
-pkgver=84.0
+pkgver=84.0.1
pkgrel=1
pkgdesc="Community-maintained fork of Firefox, focused on privacy, security and freedom."
arch=(x86_64 aarch64)
@@ -30,28 +30,32 @@ source_x86_64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/f
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
"git+https://gitlab.com/${pkgname}-community/settings.git"
"megabar.patch"
- "remove_addons.patch")
+ "remove_addons.patch"
+ "unity-menubar.patch")
source_aarch64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
"git+https://gitlab.com/${pkgname}-community/settings.git"
"megabar.patch"
"remove_addons.patch"
+ "unity-menubar.patch"
arm.patch
https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/firefox/build-arm-libopus.patch)
-sha256sums_x86_64=('23273ef0165b243f5d0908c38e7854d38070282c9b526e8d93b7503cd5f69138'
+sha256sums_x86_64=('ae5500d270a199f9a10674fbd4ba7a6beac1f260a4c009bbca8ea39967592243'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
'682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
- 'f2f7403c9abd33a7470a5861e247b488693cf8d7d55c506e7e579396b7bf11e6')
-sha256sums_aarch64=('23273ef0165b243f5d0908c38e7854d38070282c9b526e8d93b7503cd5f69138'
+ 'f2f7403c9abd33a7470a5861e247b488693cf8d7d55c506e7e579396b7bf11e6'
+ '6ca4d5a50a6645ff35da0bd2e9b606172f55123ddaec3ed1f87416c18f9800ff')
+sha256sums_aarch64=('ae5500d270a199f9a10674fbd4ba7a6beac1f260a4c009bbca8ea39967592243'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
'682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
'f2f7403c9abd33a7470a5861e247b488693cf8d7d55c506e7e579396b7bf11e6'
+ '6ca4d5a50a6645ff35da0bd2e9b606172f55123ddaec3ed1f87416c18f9800ff'
'6ca87d2ac7dc48e6f595ca49ac8151936afced30d268a831c6a064b52037f6b7'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9')
@@ -138,6 +142,9 @@ fi
# Adapted from https://github.com/WesleyBranton/userChrome.css-Customizations
patch -p1 -i ../megabar.patch
+ # Debian patch to enable global menubar
+ patch -p1 -i ../unity-menubar.patch
+
# Disabling Pocket
sed -i "s/'pocket'/#'pocket'/g" browser/components/moz.build
# this one only to remove an annoying error message:
bgstack15