aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorohfp <1813007-ohfp@users.noreply.gitlab.com>2021-01-27 16:21:45 +0100
committerohfp <1813007-ohfp@users.noreply.gitlab.com>2021-01-27 16:23:40 +0100
commite4852c50502d0e0bdd3d89ee18d74c4f70f1b8ca (patch)
treeba977c98e21adb453a2a16e1d6339486b8826934
parentport MR arch!1 (diff)
downloadlibrewolf-linux-e4852c50502d0e0bdd3d89ee18d74c4f70f1b8ca.tar.gz
librewolf-linux-e4852c50502d0e0bdd3d89ee18d74c4f70f1b8ca.tar.bz2
librewolf-linux-e4852c50502d0e0bdd3d89ee18d74c4f70f1b8ca.zip
85.0-1 – get Arch build ready
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD11
-rw-r--r--README.md8
-rwxr-xr-xbinary_tarball/scripts/5_Configure_Binary_Tarball.sh2
4 files changed, 18 insertions, 14 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 58d42b5..1d0c65b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -7,6 +7,17 @@ The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/).
This project follows the official Firefox releases, but also uses
[Arch Linux Package Versioning](https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_versioning) to mark individual releases in between versions.
+## [85.0-1] – Unreleased
+
+### Fixed
+
+- Non-Arch releases should now also have some additional startup requests removed
+
+### Changed
+
+- New upstream release 85.0
+- `dom.event.contextmenu.enabled` is now an unlocked preference
+
## [84.0.2-2] - 2021-01-20
### Fixed
diff --git a/PKGBUILD b/PKGBUILD
index b1e1b4f..5f58b54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=librewolf
_pkgname=LibreWolf
# how to get ci vars instead?
-pkgver=84.0.2
+pkgver=85.0
pkgrel=1
pkgdesc="Community-maintained fork of Firefox, focused on privacy, security and freedom."
arch=(x86_64 aarch64)
@@ -24,7 +24,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
_arch_svn=https://git.archlinux.org/svntogit/packages.git/plain/trunk
-_settings_commit=0d0cd76c4465b4be11a3460ae4bcee3500e665e4
+_settings_commit=640b375dc02c5b089f678ed16b0232d1c0cc0721
source_x86_64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
@@ -42,14 +42,14 @@ source_aarch64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/
arm.patch
https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/firefox/build-arm-libopus.patch)
-sha256sums_x86_64=('92bfd518d4f9760c897388a8e06130b171c1c43524d8af181add9daac2be7b37'
+sha256sums_x86_64=('5f03712642f5e77de4581d2ba3ee3e87cfa44c3d2fdd8fe0fb56ea05a57f7b50'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
'682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
'f2f7403c9abd33a7470a5861e247b488693cf8d7d55c506e7e579396b7bf11e6'
'6ca4d5a50a6645ff35da0bd2e9b606172f55123ddaec3ed1f87416c18f9800ff')
-sha256sums_aarch64=('92bfd518d4f9760c897388a8e06130b171c1c43524d8af181add9daac2be7b37'
+sha256sums_aarch64=('5f03712642f5e77de4581d2ba3ee3e87cfa44c3d2fdd8fe0fb56ea05a57f7b50'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
@@ -123,7 +123,8 @@ END
export CXXFLAGS+=" -g0"
export RUSTFLAGS="-Cdebuginfo=0"
- export LDFLAGS+=" -Wl,--no-keep-memory"
+ # we should have more than enough RAM on the CI spot instances.
+ # export LDFLAGS+=" -Wl,--no-keep-memory"
patch -p1 -i ../arm.patch
patch -p1 -i ../build-arm-libopus.patch
diff --git a/README.md b/README.md
index 063ba2e..92a301f 100644
--- a/README.md
+++ b/README.md
@@ -1,13 +1,5 @@
This Repository contains all the required material to build the browser on Linux platforms.
-### Status
-
-Unfortunately, at the moment we are only barely keeping up with maintenance releases following
-upstream Firefox releases. AppImage and Flatpak-releases are still to be considered experimental.
-Debian builds are already being built by a third party contributer (see !12), and will hopefully soon be
-integrated as well. We are fully aware of the issues and wishes/improvements piling up – rest assured,
-we will get to them as soon as possible!
-
### Important
The following instructions are currently outdated. The build scripts are currently meant to be
diff --git a/binary_tarball/scripts/5_Configure_Binary_Tarball.sh b/binary_tarball/scripts/5_Configure_Binary_Tarball.sh
index f589495..706126b 100755
--- a/binary_tarball/scripts/5_Configure_Binary_Tarball.sh
+++ b/binary_tarball/scripts/5_Configure_Binary_Tarball.sh
@@ -11,7 +11,7 @@ LAUNCHER_SCRIPT=$3;
CI_PROJECT_DIR=${CI_PROJECT_DIR:-$(realpath $(dirname $0)/../../)}
_SCRIPT_FOLDER=$(realpath $(dirname $0));
_EXTRACTED_TARBALL_FOLDER=$_SCRIPT_FOLDER/librewolf;
-_SETTINGS_COMMIT=0d0cd76c4465b4be11a3460ae4bcee3500e665e4
+_SETTINGS_COMMIT=640b375dc02c5b089f678ed16b0232d1c0cc0721
_SETTINGS_REPO='https://gitlab.com/librewolf-community/settings.git';
# Extracts the binary tarball
bgstack15