summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec60
1 files changed, 15 insertions, 45 deletions
diff --git a/firefox.spec b/firefox.spec
index 806f952..109480d 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,7 +1,5 @@
-ExclusiveArch: x86_64 i686
-
# Use system nspr/nss?
-%global system_nss 0
+%global system_nss 1
# Use system hunspell?
%if 0%{?fedora} > 25
@@ -82,13 +80,13 @@ ExclusiveArch: x86_64 i686
%global mozappdir %{_libdir}/%{name}
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
%global langpackdir %{mozappdir}/langpacks
-#%global tarballdir %{name}-%{version}%{?pre_version}
-%global tarballdir mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24
+%global release_hash 2f6a4d2cf42c9d59626061d45c043817cb220814
+%global tarballdir mozilla-release-%{release_hash}
-%global official_branding 0
-%global build_langpacks 0
+%global official_branding 1
+%global build_langpacks 1
-%global enable_mozilla_crashreporter 0
+%global enable_mozilla_crashreporter 1
%if !%{debug_build}
%ifarch %{ix86} x86_64
%global enable_mozilla_crashreporter 0
@@ -98,13 +96,12 @@ ExclusiveArch: x86_64 i686
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 59.0
-Release: 0.8%{?pre_tag}%{?dist}
+Release: 1%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
-#Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
-Source0: mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24.tar.bz2
+Source0: https://hg.mozilla.org/releases/mozilla-release/archive/%{release_hash}.tar.bz2
%if %{build_langpacks}
-Source1: firefox-langpacks-%{version}%{?pre_version}-20180123.tar.xz
+Source1: firefox-langpacks-%{version}%{?pre_version}-20180306.tar.xz
%endif
Source10: firefox-mozconfig
Source12: firefox-redhat-default-prefs.js
@@ -136,6 +133,7 @@ Patch36: build-missing-xlocale-h.patch
Patch37: build-jit-atomic-always-lucky.patch
# Fixing missing cacheFlush when JS_CODEGEN_NONE is used (s390x)
Patch38: build-cacheFlush-missing.patch
+Patch39: mozilla-fix-attr-order.patch
# Fedora specific patches
Patch215: firefox-enable-addons.patch
@@ -310,6 +308,7 @@ This package contains results of tests executed during build.
%endif
%patch29 -p1 -b .big-endian
%patch37 -p1 -b .jit-atomic-lucky
+%patch39 -p1 -b .fix-attr-order
%patch3 -p1 -b .arm
@@ -593,16 +592,11 @@ DESTDIR=%{buildroot} make -C objdir install
%{__mkdir_p} %{buildroot}{%{_libdir},%{_bindir},%{_datadir}/applications}
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE20}
-desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE29}
# set up the firefox start script
%{__rm} -rf %{buildroot}%{_bindir}/firefox
%{__cat} %{SOURCE21} > %{buildroot}%{_bindir}/firefox
%{__chmod} 755 %{buildroot}%{_bindir}/firefox
-%{__cat} %{SOURCE28} > %{buildroot}%{_bindir}/firefox-wayland
-%{__chmod} 755 %{buildroot}%{_bindir}/firefox-wayland
-%{__cat} %{SOURCE30} > %{buildroot}%{_bindir}/firefox-x11
-%{__chmod} 755 %{buildroot}%{_bindir}/firefox-x11
%{__install} -p -D -m 644 %{SOURCE23} %{buildroot}%{_mandir}/man1/firefox.1
@@ -801,8 +795,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files -f %{name}.lang
%{_bindir}/firefox
-%{_bindir}/firefox-wayland
-%{_bindir}/firefox-x11
%{mozappdir}/firefox
%{mozappdir}/firefox-bin
%doc %{_mandir}/man1/*
@@ -870,33 +862,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
-* Fri Feb 2 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.8
-- Fix crash when e10s is disabled and default wl_queue is processed.
-
-* Fri Feb 2 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.7
-- Fixed Firefox X11 desktop file launcher.
-
-* Thu Feb 1 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.6
-- Fixed remote window focus (mozbz#1434565).
-
-* Thu Feb 1 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.5
-- Fixed clipboard copy->paste between Firefox windows
- (mozbz#1434572).
-
-* Wed Jan 31 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.4
-- Fixed remote launch when no profile name is given.
-
-* Wed Jan 31 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.3
-- Added X11 launcher
-
-* Tue Jan 30 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.2
-- Fixed typo at startup script.
-- Added Wayland specific patches mozbz#1431052 mozbz#1432414
- mozbz#1434202
+* Tue Mar 6 2018 Martin Stransky <stransky@redhat.com> - 59.0-1
+- Updated to 59.0
-* Mon Jan 29 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.1
-- Update to Firefox 59.0 Beta 4
-- Enabled Wayland backend
+* Tue Feb 13 2018 Martin Stransky <stransky@redhat.com> - 58.0.1-3
+- Added build fix for gcc8 by Tom Callaway
* Wed Jan 24 2018 Martin Stransky <stransky@redhat.com> - 58.0-4
- Enabled second arches
bgstack15