summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec33
1 files changed, 25 insertions, 8 deletions
diff --git a/firefox.spec b/firefox.spec
index 08c5746..db73936 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -27,7 +27,7 @@
# Use system libicu?
%if 0%{?fedora} > 27
-%define system_libicu 1
+%define system_libicu 0
%else
%define system_libicu 0
%endif
@@ -67,11 +67,11 @@
%global nspr_version 4.10.10
# NSS/NSPR quite often ends in build override, so as requirement the version
# we're building against could bring us some broken dependencies from time to time.
-%global nspr_build_version %{nspr_version}
#%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
+%global nspr_build_version %{nspr_version}
%global nss_version 3.29.3
-%global nss_build_version %{nss_version}
#%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
+%global nss_build_version %{nss_version}
%endif
%if %{?system_sqlite}
@@ -90,20 +90,22 @@
%define enable_mozilla_crashreporter 0
%if !%{debug_build}
%ifarch %{ix86} x86_64
+%if 0%{?fedora} < 27
%define enable_mozilla_crashreporter 1
%endif
%endif
+%endif
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 55.0.2
-Release: 3%{?pre_tag}%{?dist}
+Version: 55.0.3
+Release: 1%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
%if %{build_langpacks}
-Source1: firefox-langpacks-%{version}%{?pre_version}-20170818.tar.xz
+Source1: firefox-langpacks-%{version}%{?pre_version}-20170901.tar.xz
%endif
Source10: firefox-mozconfig
Source12: firefox-redhat-default-prefs.js
@@ -113,6 +115,7 @@ Source23: firefox.1
Source24: mozilla-api-key
Source25: firefox-symbolic.svg
Source26: distribution.ini
+Source27: google-api-key
# Build patches
Patch0: firefox-install-dir.patch
@@ -133,6 +136,10 @@ Patch32: build-rust-ppc64le.patch
Patch33: build-ppc-s390-dom.patch
Patch34: build-cubeb-pulse-arm.patch
Patch35: build-ppc-jit.patch
+Patch36: build-missing-xlocale-h.patch
+# Always feel lucky for unsupported platforms:
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1347128
+Patch37: build-jit-atomic-always-lucky.patch
# Fedora specific patches
# Unable to install addons from https pages
@@ -147,7 +154,6 @@ Patch226: rhbz-1354671.patch
Patch229: firefox-nss-version.patch
# Upstream patches
-Patch304: mozilla-1253216.patch
Patch402: mozilla-1196777.patch
Patch406: mozilla-256180.patch
Patch407: mozilla-1348576.patch
@@ -203,6 +209,7 @@ BuildRequires: pkgconfig(gconf-2.0)
BuildRequires: yasm
Requires: mozilla-filesystem
+Requires: p11-kit-trust
%if %{?system_nss}
Requires: nspr >= %{nspr_build_version}
Requires: nss >= %{nss_build_version}
@@ -312,6 +319,7 @@ This package contains results of tests executed during build.
%ifarch ppc ppc64 ppc64le
%patch35 -p1 -b .ppc-jit
%endif
+%patch37 -p1 -b .jit-atomic-lucky
%patch3 -p1 -b .arm
@@ -329,7 +337,6 @@ This package contains results of tests executed during build.
%patch226 -p1 -b .1354671
%endif
-%patch304 -p1 -b .1253216
%patch402 -p1 -b .1196777
%patch406 -p1 -b .256180
%ifarch %{arm}
@@ -346,6 +353,7 @@ This package contains results of tests executed during build.
# Patch for big endian platforms only
%if 0%{?big_endian}
%patch26 -p1 -b .icu
+%patch36 -p2 -b .xlocale
%endif
%{__rm} -f .mozconfig
@@ -354,6 +362,7 @@ This package contains results of tests executed during build.
echo "ac_add_options --enable-official-branding" >> .mozconfig
%endif
%{__cp} %{SOURCE24} mozilla-api-key
+%{__cp} %{SOURCE27} google-api-key
%if %{?system_nss}
echo "ac_add_options --with-system-nspr" >> .mozconfig
@@ -453,6 +462,10 @@ echo "ac_add_options --with-system-icu" >> .mozconfig
%else
echo "ac_add_options --without-system-icu" >> .mozconfig
%endif
+%ifarch s390 s390x
+echo "ac_add_options --disable-ion" >> .mozconfig
+%endif
+
#---------------------------------------------------------------------
@@ -848,11 +861,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/libfreeblpriv3.chk
%{mozappdir}/libnssdbm3.chk
%{mozappdir}/libsoftokn3.chk
+%exclude %{mozappdir}/libnssckbi.so
%endif
#---------------------------------------------------------------------
%changelog
+* Fri Sep 1 2017 Jan Horak <jhorak@redhat.com> - 55.0.3-1
+- Update to 55.0.3
+
* Thu Aug 24 2017 Martin Stransky <stransky@redhat.com> - 55.0.2-3
- Enable to build with nspr-4.16.
bgstack15