summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec9
1 files changed, 6 insertions, 3 deletions
diff --git a/firefox.spec b/firefox.spec
index 92efbb1..18dda69 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,6 +1,6 @@
# Produce a build suitable for release, i.e. use PGO/LTO. You can turn it off
# when building locally to reduce build time.
-%global release_build 1
+%global release_build 0
# Run Mozilla test suite as a part of compile rpm section. Turn off when
# building locally and don't want to spend 24 hours waiting for results.
@@ -171,6 +171,7 @@ Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pr
Source1: firefox-langpacks-%{version}%{?pre_version}-20220609.tar.xz
%endif
Source2: cbindgen-vendor.tar.xz
+Source3: https://github.com/WebAssembly/wasi-sdk/releases/download/wasi-sdk-16/wasi-sysroot-16.0.tar.gz
Source10: firefox-mozconfig
Source12: firefox-redhat-default-prefs.js
Source20: firefox.desktop
@@ -317,9 +318,7 @@ BuildRequires: llvm
BuildRequires: llvm-devel
BuildRequires: clang
BuildRequires: clang-libs
-%if %{build_with_clang}
BuildRequires: lld
-%endif
BuildRequires: pipewire-devel
@@ -647,6 +646,10 @@ echo "ac_add_options --with-google-safebrowsing-api-keyfile=`pwd`/google-api-key
echo 'export NODEJS="%{_buildrootdir}/bin/node-stdout-nonblocking-wrapper"' >> .mozconfig
+# Prepare wasi sdk:
+%{__tar} xf %{SOURCE3}
+echo "ac_add_options --with-wasi-sysroot=`pwd`/wasi-sysroot" >> .mozconfig
+
# Remove executable bit to make brp-mangle-shebangs happy.
chmod -x third_party/rust/itertools/src/lib.rs
chmod a-x third_party/rust/ash/src/extensions/ext/*.rs
bgstack15