summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorChristopher Aillon <caillon@redhat.com>2011-01-25 11:18:34 -0800
committerChristopher Aillon <caillon@redhat.com>2011-01-25 11:18:34 -0800
commited92d8077dcfb9ec455f441f8277ef2e634f6989 (patch)
tree0a387582bae8b8a5a65f719bea6ad487ebbcfb06 /firefox.spec
parentUpdate the parallel build flags (diff)
downloadlibrewolf-fedora-ff-ed92d8077dcfb9ec455f441f8277ef2e634f6989.tar.gz
librewolf-fedora-ff-ed92d8077dcfb9ec455f441f8277ef2e634f6989.tar.bz2
librewolf-fedora-ff-ed92d8077dcfb9ec455f441f8277ef2e634f6989.zip
Fix up optimize flags
Don't pass the opt flags twice to moz, as that will just cause them to be duplicated in the compile lines. Remove commented out optimization flags in the mozconfig Also add a comment about why we disable cpp exceptions
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/firefox.spec b/firefox.spec
index db23a55..be56c62 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -145,7 +145,11 @@ cd %{tarballdir}
# Mozilla builds with -Wall with exception of a few warnings which show up
# everywhere in the code; so, don't override that.
-export MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//' | %{__sed} -e 's/-fexceptions/-fno-exceptions/g')
+#
+# Disable C++ exceptions since Mozilla code is not exception-safe
+#
+MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | \
+ %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS=$MOZ_OPT_FLAGS
bgstack15