summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorJan Horak <jhorak@redhat.com>2019-08-07 10:18:17 +0200
committerJan Horak <jhorak@redhat.com>2019-08-07 10:18:17 +0200
commit552b94bac781332262301392dcf065cc61abc462 (patch)
treeab1d54e3749dc9670401dc1a6305dff08646b880 /firefox.spec
parentMerge branch 'master' into f30 (diff)
downloadlibrewolf-fedora-ff-552b94bac781332262301392dcf065cc61abc462.tar.gz
librewolf-fedora-ff-552b94bac781332262301392dcf065cc61abc462.tar.bz2
librewolf-fedora-ff-552b94bac781332262301392dcf065cc61abc462.zip
Use make -j1 for debugging purposes
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec12
1 files changed, 6 insertions, 6 deletions
diff --git a/firefox.spec b/firefox.spec
index ebad0b3..05724f9 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -561,23 +561,23 @@ MOZ_SMP_FLAGS=-j1
%ifarch %{ix86}
[ -z "$RPM_BUILD_NCPUS" ] && \
RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
-[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
+#[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
%endif
%ifarch x86_64 ppc ppc64 ppc64le aarch64
[ -z "$RPM_BUILD_NCPUS" ] && \
RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
-[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
-[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
-[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
+#[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
+#[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
+#[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
%endif
export MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
export MOZ_SERVICES_SYNC="1"
export STRIP=/bin/true
%if 0%{?build_with_pgo}
-GDK_BACKEND=x11 xvfb-run ./mach build 2>&1 | cat -
+GDK_BACKEND=x11 xvfb-run ./mach build 2>&1 | cat -
%else
-env RUST_LOG=debug strace -y -f ./mach build 2>&1 | cat -
+env RUST_LOG=debug strace -y -f ./mach build -v 2>&1 | cat -
%endif
# create debuginfo for crash-stats.mozilla.com
bgstack15