summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorMartin Stransky <stransky@fedoraproject.org>2007-07-31 10:50:12 +0000
committerMartin Stransky <stransky@fedoraproject.org>2007-07-31 10:50:12 +0000
commitc6d9eb19e157f2e3035b1cf8bb2ce74edbe2ca3b (patch)
tree32cb70ec11c76a909f8b333da65e07c5adc79f70 /firefox.spec
parent- Update to 2.0.0.5 (diff)
downloadlibrewolf-fedora-ff-c6d9eb19e157f2e3035b1cf8bb2ce74edbe2ca3b.tar.gz
librewolf-fedora-ff-c6d9eb19e157f2e3035b1cf8bb2ce74edbe2ca3b.tar.bz2
librewolf-fedora-ff-c6d9eb19e157f2e3035b1cf8bb2ce74edbe2ca3b.zip
added nspluginwrapper support
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec42
1 files changed, 40 insertions, 2 deletions
diff --git a/firefox.spec b/firefox.spec
index 34b5c24..a8f616d 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -6,13 +6,16 @@
%define cairo_version 0.5
%define builddir %{_builddir}/mozilla
%define build_devel_package 1
+%define plugin_config_version 1.1
+%define plugin_config_name plugin-config-%{plugin_config_version}
+%define plugin_config_binary plugin-configuration
%define official_branding 1
Summary: Mozilla Firefox Web browser.
Name: firefox
Version: 2.0.0.5
-Release: 2%{?dist}
+Release: 3%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPL/LGPL
Group: Applications/Internet
@@ -22,6 +25,7 @@ Group: Applications/Internet
%define tarball firefox-2.0rc3-source.tar.bz2
%endif
Source0: %{tarball}
+Source1: %{plugin_config_name}.tar.gz
Source2: firefox-langpacks-%{version}-20070718.tar.bz2
Source10: firefox-mozconfig
Source11: firefox-mozconfig-branded
@@ -30,6 +34,7 @@ Source20: firefox.desktop
Source21: firefox.sh.in
Source22: firefox.png
Source23: firefox.1
+Source24: firefox-plugin-config.sh.in
Source50: firefox-xremote-client.sh.in
Source100: find-external-requires
Source101: add-gecko-provides.in
@@ -141,7 +146,7 @@ removed in favor of xulrunner-devel.
#---------------------------------------------------------------------
%prep
-%setup -q -n mozilla
+%setup -q -n mozilla -a 1
%patch1 -p1 -b .link-layout
#%patch3 -p1
#%patch4 -p1
@@ -215,11 +220,18 @@ export LDFLAGS="-Wl,-rpath,%{mozappdir}"
export MAKE="gmake %{moz_make_flags}"
make -f client.mk build
+#Build plugin configuration utility
+pushd %{plugin_config_name}
+./configure --prefix=/usr CFLAGS="$RPM_OPT_FLAGS"
+make
+popd
+
#---------------------------------------------------------------------
%install
%{__rm} -rf $RPM_BUILD_ROOT
+
DESTDIR=$RPM_BUILD_ROOT make install
%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
@@ -272,6 +284,7 @@ EOF
# own mozilla plugin dir (#135050)
%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
+%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins-wrapped
# Install langpacks
%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/extensions
@@ -345,6 +358,23 @@ install -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
+# Install plugin-config utility
+pushd %{plugin_config_name}
+DESTDIR=$RPM_BUILD_ROOT make install
+
+cd $RPM_BUILD_ROOT/usr/bin
+mv %{plugin_config_binary} $RPM_BUILD_ROOT%{mozappdir}
+
+cd $RPM_BUILD_ROOT/usr/doc
+mv plugin-config $RPM_BUILD_ROOT%{mozappdir}
+popd
+
+# set up the firefox plugin configuration script
+%{__cat} %{SOURCE24} | %{__sed} -e 's,FIREFOX_VERSION,%{version},g' > \
+ $RPM_BUILD_ROOT%{_bindir}/firefox-plugin-config
+%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/firefox-plugin-config
+
+
#---------------------------------------------------------------------
%clean
@@ -354,6 +384,7 @@ touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
%post
update-desktop-database %{_datadir}/applications
+%{mozappdir}/%{plugin_config_binary} -i -f -q > /dev/null 2>&1
%postun
update-desktop-database %{_datadir}/applications
@@ -365,9 +396,11 @@ if [ $1 -eq 0 ]; then
%{__rm} -rf %{mozappdir}/extensions
fi
+
%files
%defattr(-,root,root,-)
%{_bindir}/firefox
+%{_bindir}/firefox-plugin-config
%exclude %{_bindir}/firefox-config
%{_mandir}/man1/*
%{_datadir}/applications/mozilla-%{name}.desktop
@@ -402,6 +435,8 @@ fi
%{mozappdir}/mozilla-xremote-client
%{mozappdir}/run-mozilla.sh
%{mozappdir}/regxpcom
+%{mozappdir}/%{plugin_config_binary}
+%{mozappdir}/plugin-config/*
# XXX See if these are needed still
%{mozappdir}/updater*
@@ -427,6 +462,9 @@ fi
#---------------------------------------------------------------------
%changelog
+* Mon Jul 23 2007 Martin Stransky <stransky@redhat.com> 2.0.0.5-3
+- added nspluginwrapper support
+
* Wed Jul 18 2007 Kai Engert <kengert@redhat.com> - 2.0.0.5-2
- Update to 2.0.0.5
bgstack15