summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorKalev Lember <klember@redhat.com>2019-06-13 20:58:52 +0200
committerKalev Lember <klember@redhat.com>2019-06-13 21:06:08 +0200
commitc545b67dfc57033134762e53219bf2b4e1f46a7b (patch)
tree050edc6ad27dec560e4c0970a2c56b20d01fa610 /firefox.spec
parentbuild fix - debug_build (diff)
downloadlibrewolf-fedora-ff-c545b67dfc57033134762e53219bf2b4e1f46a7b.tar.gz
librewolf-fedora-ff-c545b67dfc57033134762e53219bf2b4e1f46a7b.tar.bz2
librewolf-fedora-ff-c545b67dfc57033134762e53219bf2b4e1f46a7b.zip
Try to fix linking with libraries in /app/lib64
When building a flatpak module, make sure to pass -L%{_libdir} to ld so that it can find libraries installed in /app/lib64. Normally, this is set through the %{__global_ldflags} macro, but firefox doesn't use that, so we need to pass the correct -L manually. This should hopefully fix the issue with pipewire-0.2 linking that recent firefox flatpak builds have run into.
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/firefox.spec b/firefox.spec
index d473fd9..7f65b9e 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -542,6 +542,11 @@ MOZ_LINK_FLAGS="-Wl,--no-keep-memory"
echo "ac_add_options --enable-linker=gold" >> .mozconfig
%endif
%endif
+%if 0%{?flatpak}
+# Make sure the linker can find libraries in /app/lib64 as we don't use
+# __global_ldflags that normally sets this.
+MOZ_LINK_FLAGS="$MOZ_LINK_FLAGS -L%{_libdir}"
+%endif
%ifarch %{arm} %{ix86}
export RUSTFLAGS="-Cdebuginfo=0"
%endif
bgstack15