summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorMartin Stransky <stransky@redhat.com>2021-01-14 14:06:33 +0100
committerMartin Stransky <stransky@redhat.com>2021-01-14 14:06:33 +0100
commit6823826f79bf9a03ee8f623a5e091960b32786e9 (patch)
tree98aef56047a3e0dedeba67ae06adf6e28603f59c /firefox.spec
parentMerge branch 'master' into f33 (diff)
parentfirefox test package name fix (diff)
downloadlibrewolf-fedora-ff-6823826f79bf9a03ee8f623a5e091960b32786e9.tar.gz
librewolf-fedora-ff-6823826f79bf9a03ee8f623a5e091960b32786e9.tar.bz2
librewolf-fedora-ff-6823826f79bf9a03ee8f623a5e091960b32786e9.zip
Merge branch 'master' into f33
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec54
1 files changed, 35 insertions, 19 deletions
diff --git a/firefox.spec b/firefox.spec
index 26106f0..8993c6c 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,9 +1,30 @@
-# Set to true if it's going to be submitted as update.
+# Produce a build suitable for release, i.e. use PGO/LTO. You can turn it off
+# when building locally to reduce build time.
%global release_build 1
+
+# Run Mozilla test suite as a part of compile rpm section. Turn off when
+# building locally and don't want to spend 24 hours waiting for results.
+%global run_firefox_tests 1
+
+# Don't create debuginfo rpm packages. It reduces build time as
+# exctracting debuginfo takes long time.
+%global create_debuginfo 1
+
+# Produce debug (non-optimized) package build. Suitable for debugging only
+# as the build is *very* slow.
%global debug_build 0
+
+%global system_nss 1
%global build_with_clang 0
%global build_with_asan 0
-%global run_firefox_tests 1
+%global test_offscreen 1
+%global test_on_wayland 0
+
+# There are still build problems on s390x, see
+# https://koji.fedoraproject.org/koji/taskinfo?taskID=55048351
+# https://bugzilla.redhat.com/show_bug.cgi?id=1897522
+ExcludeArch: s390x
+
# Temporary disable tests on Rawhide/arm/i686 due to failures
%if 0%{?fedora} > 33
%ifarch armv7hl
@@ -13,15 +34,6 @@
%global run_firefox_tests 0
%endif
%endif
-%global test_offscreen 1
-%global test_on_wayland 0
-%global create_debuginfo 1
-%global system_nss 1
-
-# There are still build problems on s390x, see
-# https://koji.fedoraproject.org/koji/taskinfo?taskID=55048351
-# https://bugzilla.redhat.com/show_bug.cgi?id=1897522
-ExcludeArch: s390x
%ifarch armv7hl
%global create_debuginfo 0
@@ -135,7 +147,7 @@ ExcludeArch: s390x
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 84.0.2
-Release: 4%{?pre_tag}%{?dist}
+Release: 5%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
@@ -376,9 +388,9 @@ Summary: Results of testsuite
%description -n %{testsuite_pkg_name}
This package contains results of tests executed during build.
%files -n %{testsuite_pkg_name}
-/%{version}%_%{release}/test_results
-/%{version}%_%{release}/test_summary.txt
-/%{version}%_%{release}/failures-*
+/%{version}-%{release}/test_results
+/%{version}-%{release}/test_summary.txt
+/%{version}-%{release}/failures-*
%endif
#---------------------------------------------------------------------
@@ -882,10 +894,10 @@ sed -i -e "s/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/" %{buildroot}/%{moz
%endif
%if 0%{?run_firefox_tests}
-%{__mkdir_p} %{buildroot}/%{version}%_%{release}/test_results
-%{__cp} test_results/* %{buildroot}/%{version}%_%{release}/test_results
-%{__cp} test_summary.txt %{buildroot}/%{version}%_%{release}/
-%{__cp} failures-* %{buildroot}/%{version}%_%{release}/ || true
+%{__mkdir_p} %{buildroot}/%{version}-%{release}/test_results
+%{__cp} test_results/* %{buildroot}/%{version}-%{release}/test_results
+%{__cp} test_summary.txt %{buildroot}/%{version}-%{release}/
+%{__cp} failures-* %{buildroot}/%{version}-%{release}/ || true
%endif
# Default
@@ -1021,6 +1033,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Thu Jan 14 2021 Martin Stransky <stransky@redhat.com> - 84.0.2-5
+- Removed some failing tests.
+- Spec file tweaks.
+
* Tue Jan 12 2021 Martin Stransky <stransky@redhat.com> - 84.0.2-4
- Enabled LTO in Firefox build system.
bgstack15