summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
authorChristopher Aillon <caillon@redhat.com>2011-04-15 17:10:51 -0700
committerChristopher Aillon <caillon@redhat.com>2011-04-15 17:10:51 -0700
commit5f70bce5051711890a78ef29420ef209a932ae16 (patch)
tree0253b6cd72b3fc86c4e5c302880377f90ab0d777 /firefox.spec
parentUpdate scriptlets per latest guidelines (diff)
downloadlibrewolf-fedora-ff-5f70bce5051711890a78ef29420ef209a932ae16.tar.gz
librewolf-fedora-ff-5f70bce5051711890a78ef29420ef209a932ae16.tar.bz2
librewolf-fedora-ff-5f70bce5051711890a78ef29420ef209a932ae16.zip
Move %preun before the %post scriptlets
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec18
1 files changed, 9 insertions, 9 deletions
diff --git a/firefox.spec b/firefox.spec
index cc10598..cd0e074 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -296,6 +296,15 @@ sed -i -e "s/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/" $RPM_BUILD_ROOT/%{
#---------------------------------------------------------------------
+%preun
+# is it a final removal?
+if [ $1 -eq 0 ]; then
+ %{__rm} -rf %{mozappdir}/components
+ %{__rm} -rf %{mozappdir}/extensions
+ %{__rm} -rf %{mozappdir}/plugins
+ %{__rm} -rf %{langpackdir}
+fi
+
%post
update-desktop-database &> /dev/null || :
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
@@ -307,15 +316,6 @@ if [ $1 -eq 0 ] ; then
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi
-%preun
-# is it a final removal?
-if [ $1 -eq 0 ]; then
- %{__rm} -rf %{mozappdir}/components
- %{__rm} -rf %{mozappdir}/extensions
- %{__rm} -rf %{mozappdir}/plugins
- %{__rm} -rf %{langpackdir}
-fi
-
%posttrans
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
bgstack15