summaryrefslogtreecommitdiff
path: root/scripts/prep-librewolf-dpkg.sh
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/prep-librewolf-dpkg.sh')
-rwxr-xr-xscripts/prep-librewolf-dpkg.sh31
1 files changed, 9 insertions, 22 deletions
diff --git a/scripts/prep-librewolf-dpkg.sh b/scripts/prep-librewolf-dpkg.sh
index 9859cd5..a15550d 100755
--- a/scripts/prep-librewolf-dpkg.sh
+++ b/scripts/prep-librewolf-dpkg.sh
@@ -18,7 +18,7 @@
# Dependencies:
# wget, git, tar, awk, sed
-# Aborts the script upon any faliure
+# Aborts the script upon any failure
set -e;
#####################################
@@ -82,7 +82,8 @@ test -z "${SKIP_EXTRACT}" && {
# test -z "${SKIP_GIT}" && (
# yes, use a sub-shell because of this cd. pushd is a bash builtin, but we are using sh and not bash.
# cd "${git_source_dir}"
- git clone "${librewolf_common_url}" ${git_source_dir}/common || : ; ( cd "${git_source_dir}/common" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
+ lw_cv="${lw_common_version}" ; test -z "${lw_cv}" && lw_cv=${librewolf_version}
+ git clone "${librewolf_common_url}" ${git_source_dir}/common || : ; ( cd "${git_source_dir}/common" ; git checkout master ; git pull ; git checkout "v${lw_cv}" ; )
git clone "${librewolf_settings_url}" ${git_source_dir}/settings || : ; ( cd "${git_source_dir}/settings" ; git checkout master ; git pull ; )
git clone "${librewolf_linux_url}" ${git_source_dir}/linux || : ; ( cd "${git_source_dir}/linux" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
@@ -176,7 +177,6 @@ if test "${DISTRO}" = "ubuntu" ; then
"${git_source_dir}"/common/patches/urlbarprovider-interventions.patch \
"${git_source_dir}"/common/patches/sed-patches/remove-internal-plugin-certs.patch \
"${git_source_dir}"/common/patches/sed-patches/allow-searchengines-non-esr.patch \
- "${git_source_dir}"/common/patches/search-config.patch \
"${git_source_dir}"/common/patches/sed-patches/stop-undesired-requests.patch \
"${git_source_dir}"/common/patches/about-dialog.patch \
"${debian_dir}"/patches/librewolf/
@@ -190,7 +190,6 @@ librewolf/browser-confvars.patch -p1
librewolf/urlbarprovider-interventions.patch -p1
librewolf/remove-internal-plugin-certs.patch -p1
librewolf/allow-searchengines-non-esr.patch -p1
-#librewolf/search-config.patch -p1
librewolf/stop-undesired-requests.patch -p1
librewolf/about-dialog.patch -p1
EOF
@@ -204,7 +203,6 @@ else
"${git_source_dir}"/common/patches/urlbarprovider-interventions.patch \
"${git_source_dir}"/common/patches/sed-patches/remove-internal-plugin-certs.patch \
"${git_source_dir}"/common/patches/sed-patches/allow-searchengines-non-esr.patch \
- "${git_source_dir}"/common/patches/search-config.patch \
"${git_source_dir}"/common/patches/sed-patches/stop-undesired-requests.patch \
"${git_source_dir}"/common/patches/about-dialog.patch \
"${git_source_dir}"/linux/deb_patches/*.patch \
@@ -226,7 +224,6 @@ librewolf/browser-confvars.patch -p1
librewolf/urlbarprovider-interventions.patch -p1
librewolf/remove-internal-plugin-certs.patch -p1
librewolf/allow-searchengines-non-esr.patch -p1
-#librewolf/search-config.patch -p1
librewolf/stop-undesired-requests.patch -p1
librewolf/about-dialog.patch -p1
librewolf/mozilla_dirs.patch -p1
@@ -239,22 +236,8 @@ librewolf/remove-organization-policy-banner.patch -p1
librewolf/remove-snippets-from-home.patch -p1
librewolf/sanitizing-description.patch -p1
EOF
- # Fixes to the LibreWolf patches for version 95.0
- patch "${debian_dir}/patches/librewolf/remove_addons.patch" <<EOF
-diff --git a/patches/remove_addons.patch b/patches/remove_addons.patch
-index a6585ed..3487f6d 100644
---- a/patches/remove_addons.patch
-+++ b/patches/remove_addons.patch
-@@ -13,7 +13,7 @@ index 269dcb2..ed7c31d 100644
- - "report-site-issue",
- "pictureinpicture",
- "proxy-failover",
-- ]
-+ "search-detection",
- diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
- index 496379c..dd6f359 100644
- --- a/browser/locales/Makefile.in
-EOF
+ # Fixes to the LibreWolf patches for version 95.0.1
+ # None yet
fi
# observe that build-with-libstdc++-7 is disabled for this dpkg. Debian builds Firefox with gcc, not clang.
@@ -310,6 +293,10 @@ rm -rf "${debian_dir}"/librewolf_settings
cp -pr "${git_source_dir}"/settings "${debian_dir}"/librewolf_settings
rm -rf "${debian_dir}"/librewolf_settings/.git*
+cp -p "${git_source_dir}"/common/source_files/search-config.json "${debian_dir}"/
+sed -i -r "${debian_dir}"/rules \
+ -e '/override_dh_auto_configure/a{ cp -pf debian/search-config.json services/settings/dumps/main/'
+
if test "${DISTRO}" = "debian" ; then
cat <<EOF >> "${debian_dir}"/browser.install.in
bgstack15