aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-compile.patch67
-rw-r--r--debian/patches/series1
2 files changed, 68 insertions, 0 deletions
diff --git a/debian/patches/fix-compile.patch b/debian/patches/fix-compile.patch
new file mode 100644
index 0000000..4ffa97d
--- /dev/null
+++ b/debian/patches/fix-compile.patch
@@ -0,0 +1,67 @@
+--- a/etpo/lexer.l
++++ b/etpo/lexer.l
+@@ -62,6 +62,8 @@ error_code|ec { yylval.sval = g_strdup(
+ static GList *filenames = NULL, *filename = NULL;
+ const char *currentfile = NULL;
+
++int yyerror(void);
++
+ int
+ yyerror(void)
+ {
+--- a/etpo/grammar.h
++++ b/etpo/grammar.h
+@@ -40,6 +40,8 @@
+ extern int yydebug;
+ #endif
+
++extern int yylex (void);
++
+ /* Token type. */
+ #ifndef YYTOKENTYPE
+ # define YYTOKENTYPE
+--- a/etpo/grammar.c
++++ b/etpo/grammar.c
+@@ -88,6 +88,9 @@
+ static const char *table = "unknown";
+ extern const char *currentfile;
+
++extern int yylex(void);
++extern int yyerror();
++
+ #line 92 "grammar.c" /* yacc.c:339 */
+
+ # ifndef YY_NULLPTR
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -26,7 +26,7 @@ $(service_DATA): $(service_in_files) Mak
+ sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@
+
+ @INTLTOOL_XML_RULE@
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metainfo
+ appdata_in_files = krb5-auth-dialog.appdata.xml.in
+ appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -434,7 +434,7 @@ dist_convert_DATA = org.gnome.KrbAuthDia
+ servicedir = $(datadir)/dbus-1/services
+ service_in_files = org.gnome.KrbAuthDialog.service.in
+ service_DATA = $(service_in_files:.service.in=.service)
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metainfo
+ appdata_in_files = krb5-auth-dialog.appdata.xml.in
+ appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+ krb5_auth_dialog_SOURCES = \
+--- a/src/krb5-auth-dialog.1.in
++++ b/src/krb5-auth-dialog.1.in
+@@ -17,7 +17,7 @@ credentials, prompting the user for what
+
+ .TP
+ \fB--auto\fR
+-If this option is specified, \fkrb5-auth-dialog\f will start only if it
++If this option is specified, \fBkrb5-auth-dialog\fR will start only if it
+ finds that the user has Kerberos credentials. This may be used to
+ ensure that only users who actually use Kerberos see the program.
+ Note that in some settings, users may authenticate to Kerberos at a
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ae688c9
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+fix-compile.patch
bgstack15