aboutsummaryrefslogtreecommitdiff
path: root/preferences/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2009-04-04 15:00:44 +0200
committerGuido Günther <agx@sigxcpu.org>2009-04-04 15:00:44 +0200
commit61675c0b44f15c2f1760c7f192321e61f174daaa (patch)
tree1d8e5cc6f09fd48a8b695be575b200224af8341f /preferences/Makefile.am
parentImported Upstream version 0.8+svn136 (diff)
downloadkrb5-auth-dialog-61675c0b44f15c2f1760c7f192321e61f174daaa.tar.gz
krb5-auth-dialog-61675c0b44f15c2f1760c7f192321e61f174daaa.tar.bz2
krb5-auth-dialog-61675c0b44f15c2f1760c7f192321e61f174daaa.zip
Imported Upstream version 0.8+svn141
Diffstat (limited to 'preferences/Makefile.am')
-rw-r--r--preferences/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/preferences/Makefile.am b/preferences/Makefile.am
new file mode 100644
index 0000000..83541ea
--- /dev/null
+++ b/preferences/Makefile.am
@@ -0,0 +1,42 @@
+NULL =
+
+INCLUDES = \
+ -I $(top_srcdir)/src/ \
+ -DKA_DATA_DIR=\""$(pkgdatadir)"\" \
+ -DLOCALE_DIR=\""$(localedir)/"\" \
+ $(NULL)
+
+bin_PROGRAMS = krb5-auth-dialog-preferences
+
+schemadir = $(sysconfdir)/gconf/schemas
+
+krb5_auth_dialog_preferences_SOURCES = \
+ krb5-auth-dialog-preferences.c \
+ ../src/krb5-auth-gconf-tools.c \
+ ../src/krb5-auth-gconf-tools.h \
+ $(NULL)
+
+krb5_auth_dialog_preferences_LDADD = \
+ @GCONF_LIBS@ \
+ @GLADE_LIBS@ \
+ @GTK_LIBS@ \
+ $(NULL)
+
+desktopdir = $(datadir)/applications
+desktop_in_files = krb5-auth-dialog-preferences.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+@INTLTOOL_DESKTOP_RULE@
+
+pkgdatadir = $(datadir)/krb5-auth-dialog
+pkgdata_DATA = \
+ krb5-auth-dialog-preferences.glade
+
+CLEANFILES = \
+ $(desktop_DATA) \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(desktop_in_files) \
+ $(pkgdata_DATA) \
+ $(NULL)
bgstack15