aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2009-07-13 18:46:06 +0200
committerGuido Günther <agx@sigxcpu.org>2009-07-13 18:46:06 +0200
commit7dfce86b3a06e5e5aa78e269df4d6c53b140024b (patch)
tree616beee41b26507b52fc6be319eb7c0ae6b3e3a5 /configure.ac
parentImported Upstream version 0.11 (diff)
downloadkrb5-auth-dialog-7dfce86b3a06e5e5aa78e269df4d6c53b140024b.tar.gz
krb5-auth-dialog-7dfce86b3a06e5e5aa78e269df4d6c53b140024b.tar.bz2
krb5-auth-dialog-7dfce86b3a06e5e5aa78e269df4d6c53b140024b.zip
Imported Upstream version 0.12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b32f51..dd9115b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([krb5-auth-dialog], [0.11])
+AC_INIT([krb5-auth-dialog], [0.12])
AC_CONFIG_SRCDIR(src/krb5-auth-dialog.c)
dnl Make automake keep quiet about wildcards & other GNUmake-isms
AM_INIT_AUTOMAKE([-Wno-portability])
@@ -57,6 +57,16 @@ if test x"$enable_debug" = x"yes"; then
AC_DEFINE(ENABLE_DEBUG, 1, [whether debugging is enabled])
fi
+dnl check for location of opensc-pkcs11 helper used for pkinit
+AC_ARG_WITH([pkcs11],
+ [AS_HELP_STRING([--with-pkcs11],
+ [set path of PKCS11 smartcard helper @<:@default=/usr/lib/opensc/opensc-pkcs11.so@:>@])],
+ [],
+ [with_pkcs11=/usr/lib/opensc/opensc-pkcs11.so])
+SC_PKCS11="$with_pkcs11"
+AC_SUBST(SC_PKCS11)
+AC_DEFINE_UNQUOTED([SC_PKCS11],["$SC_PKCS11"],[PKCS11 smartcard helper])
+
AC_PATH_PROG([KRB5_CONFIG], krb5-config, none, $PATH:/usr/kerberos/bin)
if test "x$KRB5_CONFIG" != "xnone"; then
bgstack15