aboutsummaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2009-03-01 15:00:15 +0100
committerGuido Günther <agx@sigxcpu.org>2009-03-01 15:00:15 +0100
commitd0f7048e94abe3371aeeba6f5cd115959e332b09 (patch)
treec4bca2f9d8c6e2646cee38f6ababc8ac1634887b /autogen.sh
parentImported Upstream version 0.8 (diff)
downloadkrb5-auth-dialog-d0f7048e94abe3371aeeba6f5cd115959e332b09.tar.gz
krb5-auth-dialog-d0f7048e94abe3371aeeba6f5cd115959e332b09.tar.bz2
krb5-auth-dialog-d0f7048e94abe3371aeeba6f5cd115959e332b09.zip
Imported Upstream version 0.8+svn128
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh21
1 files changed, 21 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 0000000..4536c2d
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+# Run this to generate all the initial makefiles, etc.
+
+srcdir=`dirname $0`
+test -z "$srcdir" && srcdir=.
+REQUIRED_AUTOMAKE_VERSION=1.7
+PKG_NAME=krb5-auth-dialog
+
+(test -f $srcdir/configure.ac \
+ && test -f $srcdir/src/krb5-auth-dialog.c) || {
+ echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
+ echo " top-level $PKG_NAME directory"
+ exit 1
+}
+
+
+which gnome-autogen.sh || {
+ echo "You need to install gnome-common from the GNOME CVS"
+ exit 1
+}
+USE_GNOME2_MACROS=1 . gnome-autogen.sh
bgstack15