aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoshua M. Boniface <joshua@boniface.me>2024-02-23 12:41:22 -0500
committerGitHub <noreply@github.com>2024-02-23 12:41:22 -0500
commit0631c2d5546f49922dff17143acc4d949fae0e86 (patch)
tree4e38113afed2d057ee1d9140d77fee9d44ce1000 /debian/rules
parentUpdate repository script to use BASEDIR (diff)
parentApply suggestions (diff)
downloadjellyfin-packaging-0631c2d5546f49922dff17143acc4d949fae0e86.tar.gz
jellyfin-packaging-0631c2d5546f49922dff17143acc4d949fae0e86.tar.bz2
jellyfin-packaging-0631c2d5546f49922dff17143acc4d949fae0e86.zip
Merge pull request #1 from Gauvino/master
Refactor jellyfin-packaging
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 678c4d8..e8a07bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,7 +42,7 @@ override_dh_auto_build:
cd jellyfin-server && dotnet publish -maxcpucount:1 --configuration $(CONFIG) \
--output='$(CURDIR)/build/usr/lib/jellyfin/bin' --self-contained --runtime $(DOTNETRUNTIME) \
-p:DebugSymbols=false -p:DebugType=none Jellyfin.Server
- rm $(CURDIR)/build/usr/lib/jellyfin/bin/libcoreclrtraceptprovider.so
+ rm -f $(CURDIR)/build/usr/lib/jellyfin/bin/libcoreclrtraceptprovider.so
cd jellyfin-web && npm ci --no-audit --unsafe-perm && \
npm run build:production && mv $(CURDIR)/jellyfin-web/dist $(CURDIR)/build/web
bgstack15