aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-03-11 17:53:18 -0400
committerB Stack <bgstack15@gmail.com>2020-03-11 17:53:18 -0400
commit61bb7a27543b9caa57e9cf39d9d10131d5af674d (patch)
tree56623c8a211677ae53cdfc2b2d365af5f20714aa /debian/rules
parentinitial commit (diff)
downloadfreeipa-helper-61bb7a27543b9caa57e9cf39d9d10131d5af674d.tar.gz
freeipa-helper-61bb7a27543b9caa57e9cf39d9d10131d5af674d.tar.bz2
freeipa-helper-61bb7a27543b9caa57e9cf39d9d10131d5af674d.zip
add debian/
added the deplist feature to Makefile to support debuild
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8e199c0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+APPNAME=freeipa-helper
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr DEFAULTDIR='$$(DESTDIR)/etc/default'
+
+override_dh_gencontrol:
+ printf "misc:Depends=" > debian/${APPNAME}.substvars
+ make -C src deplist DISTRO=devuan SEPARATOR=',' | grep -vE 'make\[[0-9]' >> debian/${APPNAME}.substvars
+ dh_gencontrol
bgstack15